summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/texi2html-i18n.patch
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-08-16 00:56:42 -0500
committerEric Bavier <bavier@member.fsf.org>2014-08-16 11:07:03 -0500
commitffbf749e6a7ec48001bd4fefb0f6df193b6de7ab (patch)
tree6be867eabb653ab5350b65d30efacc2312a0ab26 /gnu/packages/patches/texi2html-i18n.patch
parentcb8b285adf850acb8979c3c83febda38d4a23abd (diff)
downloadguix-patches-ffbf749e6a7ec48001bd4fefb0f6df193b6de7ab.tar
guix-patches-ffbf749e6a7ec48001bd4fefb0f6df193b6de7ab.tar.gz
gnu: texi2html: Fix tests in the absense of gettext.
* gnu/packages/patches/texi2html-i18n.patch: New patch. * gnu/packages/texinfo.scm (texi2html)[source]: Use it. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches/texi2html-i18n.patch')
-rw-r--r--gnu/packages/patches/texi2html-i18n.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/patches/texi2html-i18n.patch b/gnu/packages/patches/texi2html-i18n.patch
new file mode 100644
index 0000000000..eba903d068
--- /dev/null
+++ b/gnu/packages/patches/texi2html-i18n.patch
@@ -0,0 +1,50 @@
+Do not try to regenerate po files; use the reference files that are packaged
+in the tarball.
+
+--- a/Makefile.in 2010-06-30 17:02:28.000000000 -0500
++++ b/Makefile.in 2014-08-16 00:22:38.447050269 -0500
+@@ -1022,15 +1022,7 @@
+
+ i18n/en.thl i18n/: $(po_document_dir)/po_document/$(PACKAGE)_document.pot
+ $(MKDIR_P) i18n
+- if test '$(USE_NLS)' = 'yes'; then \
+- for file in "$(srcdir)/$(po_document_dir)/po_document/"*".po"; do lang=`basename "$$file" .po | sed 's/\..*//'`; \
+- test "$$lang" = 'en' && continue; \
+- msgexec -i "$$file" "$(srcdir)/gettext_to_separated.pl" | "$(srcdir)/separated_to_hash.pl" $$lang > i18n/$$lang.thl; \
+- done; \
+- msgexec -i $< "$(srcdir)/gettext_to_separated.pl" | "$(srcdir)/separated_to_hash.pl" en > i18n/en.thl; \
+- else \
+- cp -p i18n_ref/*.thl i18n; \
+- fi
++ cp -p i18n_ref/*.thl i18n
+
+ i18n_ref:
+ $(MKDIR_P) i18n_ref
+
+Have install-sh install .mo files locally for in-source tests, so that msgfmt
+is not needed.
+
+--- a/Makefile.in 2010-06-30 17:02:28.000000000 -0500
++++ b/Makefile.in 2014-08-16 00:22:38.447050269 -0500
+@@ -1052,19 +1044,8 @@
+ # update the po files, and install locally the .mo files for the in
+ # source tests
+ check-local: makeinfo.pl texi2any.pl
+- if test '$(USE_NLS)' = 'yes'; then \
+- cd $(po_document_dir)/po_document && $(MAKE) $(AM_MAKEFLAGS) update-po; \
+- fi
+- rm -rf locales
+- for file in "$(srcdir)/$(po_document_dir)/po_document/"*.po; do \
+- basename=`basename "$$file" .po` ; \
+- $(MKDIR_P) "locales/$$basename/LC_MESSAGES/" ; \
+- if test '$(USE_NLS)' = 'yes'; then \
+- $(MSGFMT) "$$file" -o "locales/$$basename/LC_MESSAGES/texi2html_document.mo" ; \
+- else \
+- cp -p "$(srcdir)/$(po_document_dir)/po_document/$$basename.mo" "locales/$$basename/LC_MESSAGES/texi2html_document.mo" ; \
+- fi; \
+- done
++ $(MAKE) -C po_document localedir="$(abs_srcdir)/locales" install-data
++ $(MAKE) -C po_messages localedir="$(abs_srcdir)/locales" install-data
+
+ makeinfo.pl texi2any.pl:
+ -$(LN_S) $(srcdir)/texi2html.pl $@