summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/texi2html-document-encoding.patch
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-07-25 16:37:44 -0500
committerEric Bavier <bavier@member.fsf.org>2014-08-11 12:22:53 -0500
commitc5d837684359e3629c4ac96297a25d1165edcb39 (patch)
treed04319f6c260d38f2b32caa547429af2672ec89d /gnu/packages/patches/texi2html-document-encoding.patch
parent3d6e65d529d93743ba3a5d6ddef0f28894fc4591 (diff)
downloadguix-patches-c5d837684359e3629c4ac96297a25d1165edcb39.tar
guix-patches-c5d837684359e3629c4ac96297a25d1165edcb39.tar.gz
gnu: Add texi2html.
* gnu/packages/texinfo.scm (texi2html): New variable. * gnu/packages/patches/texi2html-document-encoding.patch: New patch. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches/texi2html-document-encoding.patch')
-rw-r--r--gnu/packages/patches/texi2html-document-encoding.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/patches/texi2html-document-encoding.patch b/gnu/packages/patches/texi2html-document-encoding.patch
new file mode 100644
index 0000000000..1469b67fa6
--- /dev/null
+++ b/gnu/packages/patches/texi2html-document-encoding.patch
@@ -0,0 +1,31 @@
+Patch derived from discussion at https://savannah.nongnu.org/bugs/?37503
+
+--- texi2html-5.0/texi2html.pl 2010-06-30 17:01:27.000000000 -0500
++++ texi2html-5.0/texi2html.pl 2014-07-09 01:17:57.062990582 -0500
+@@ -2589,7 +2589,12 @@
+ my $state = shift;
+
+ # FIXME this should be done only once, for @documentencoding
+- my $encoding = lc(Texi2HTML::Config::get_conf('DOCUMENT_ENCODING'));
++ my $encoding;
++ my $input_encoding = Texi2HTML::Config::get_conf('documentencoding');
++ if (defined($input_encoding))
++ {
++ $encoding = lc($input_encoding);
++ }
+ if (defined($encoding) and $encoding ne '' and exists($Texi2HTML::Config::t2h_encoding_aliases{$encoding}))
+ {
+ $encoding = $Texi2HTML::Config::t2h_encoding_aliases{$encoding};
+
+Fix failures in test/encodings.
+
+--- texi2html-5.0/texi2html.pl 2014-07-09 01:22:06.000000000 -0500
++++ texi2html-5.0/texi2html.pl 2014-07-10 23:23:47.182097602 -0500
+@@ -53,6 +53,7 @@
+ # for translations
+ #use encoding 'utf8';
+ #use utf8;
++binmode STDERR, ':encoding(utf8)';
+
+ #
+ # According to