summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/teensy-loader-cli-help.patch
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-06-14 23:14:13 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-15 15:27:48 +0200
commitd3a858cb32b68bf2e2ebb97c67dfca97ab59690d (patch)
treeea28617ca929778d2f614c1fa1a5d1eac955397e /gnu/packages/patches/teensy-loader-cli-help.patch
parent1ec32f4a9d35f235a9947f288370af1445f8ab8b (diff)
downloadguix-patches-d3a858cb32b68bf2e2ebb97c67dfca97ab59690d.tar
guix-patches-d3a858cb32b68bf2e2ebb97c67dfca97ab59690d.tar.gz
gnu: Add teensy-loader-cli.
* gnu/packages/flashing-tools.scm (teensy-loader-cli): New variable. * gnu/packages/patches/teensy-loader-cli-help.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/teensy-loader-cli-help.patch')
-rw-r--r--gnu/packages/patches/teensy-loader-cli-help.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/patches/teensy-loader-cli-help.patch b/gnu/packages/patches/teensy-loader-cli-help.patch
new file mode 100644
index 0000000000..8b3fda128a
--- /dev/null
+++ b/gnu/packages/patches/teensy-loader-cli-help.patch
@@ -0,0 +1,33 @@
+Add support for '-h' (help).
+
+https://github.com/PaulStoffregen/teensy_loader_cli/pull/26
+
+---
+ teensy_loader_cli.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/teensy_loader_cli.c b/teensy_loader_cli.c
+index d4a6cc5..0a06209 100644
+--- a/teensy_loader_cli.c
++++ b/teensy_loader_cli.c
+@@ -37,7 +37,8 @@ void usage(const char *err)
+ {
+ if(err != NULL) fprintf(stderr, "%s\n\n", err);
+ fprintf(stderr,
+- "Usage: teensy_loader_cli --mcu=<MCU> [-w] [-h] [-n] [-b] [-v] <file.hex>\n"
++ "Usage: teensy_loader_cli --mcu=<MCU> [-h] [-w] [-n] [-b] [-v] <file.hex>\n"
++ "\t-h : Print this help message\n"
+ "\t-w : Wait for device to appear\n"
+ "\t-r : Use hard reboot if device not online\n"
+ "\t-s : Use soft reboot if device not online (Teensy3.x only)\n"
+@@ -1081,6 +1082,7 @@ void parse_flag(char *arg)
+ int i;
+ for(i=1; arg[i]; i++) {
+ switch(arg[i]) {
++ case 'h': usage(NULL); break;
+ case 'w': wait_for_device_to_appear = 1; break;
+ case 'r': hard_reboot_device = 1; break;
+ case 's': soft_reboot_device = 1; break;
+--
+2.7.4
+