summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/tao-fix-parser-types.patch
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-07-10 17:48:06 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-07-16 10:07:57 +0200
commitf5340e004590d3775157b335efa8a1525605a55c (patch)
tree2f8dd7714c3db5c16bec0b7b5834c2bafed67d5b /gnu/packages/patches/tao-fix-parser-types.patch
parent03f9a8c35be387f37badcd2c830ac7414ac17225 (diff)
downloadguix-patches-f5340e004590d3775157b335efa8a1525605a55c.tar
guix-patches-f5340e004590d3775157b335efa8a1525605a55c.tar.gz
gnu: Add tao.
* gnu/packages/patches/tao-add-missing-headers.patch, gnu/packages/patches/tao-fix-parser-types.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/audio.scm (tao): New variable.
Diffstat (limited to 'gnu/packages/patches/tao-fix-parser-types.patch')
-rw-r--r--gnu/packages/patches/tao-fix-parser-types.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/patches/tao-fix-parser-types.patch b/gnu/packages/patches/tao-fix-parser-types.patch
new file mode 100644
index 0000000000..5dcf3fc2ea
--- /dev/null
+++ b/gnu/packages/patches/tao-fix-parser-types.patch
@@ -0,0 +1,26 @@
+Taken from Debian:
+https://salsa.debian.org/multimedia-team/taopm/-/raw/master/debian/patches/02-fix-parser-yyerror.diff
+
+Description: Use a constant char, dummy comment.
+Author: Tiago Bortoletto Vaz <tiago@debian.org>
+Last-Update: 2013-04-17
+--- a/taoparse/taoparser.yy
++++ b/taoparse/taoparser.yy
+@@ -23,7 +23,7 @@
+ #include <stdio.h>
+ #include "taoparserdefs.h"
+
+-int yyerror(char *s);
++int yyerror(const char *s);
+
+ //#ifdef LINUX
+ int yylex(void);
+@@ -2924,7 +2924,7 @@
+ }
+
+
+-int yyerror (char *s)
++int yyerror (const char *s)
+ {
+ parse_error(what_I_expected_here);
+ std::cout << "PARSE_FAILED";