summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/slim-config.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-02-05 22:18:14 +0100
committerLudovic Courtès <ludo@gnu.org>2014-02-05 22:18:14 +0100
commit16686a902276c827455d78860dd62aaa68922cd2 (patch)
tree193ddf7c2d66f6c34b3da952c2e3d063cfdf21fb /gnu/packages/patches/slim-config.patch
parent1d07e9316a84a47da54469d63b1825368c0db720 (diff)
downloadguix-patches-16686a902276c827455d78860dd62aaa68922cd2.tar
guix-patches-16686a902276c827455d78860dd62aaa68922cd2.tar.gz
gnu: slim: Upgrade to 1.3.6; allow the choice of a config file at run time.
* gnu/packages/slim.scm (slim): Upgrade to 1.3.6. Add patches. Comment out systemd-related stuff from CMakeLists.txt. Add "-DBUILD_SHARED_LIBS=OFF" and "-DCMAKE_SKIP_BUILD_RPATH=ON" to #:configure-flags. Adjust 'home-page' field. * gnu/packages/patches/slim-config.patch, gnu/packages/patches/slim-session.patch: New files. * gnu-system.am (dist_patch_DATA): Add them.
Diffstat (limited to 'gnu/packages/patches/slim-config.patch')
-rw-r--r--gnu/packages/patches/slim-config.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/patches/slim-config.patch b/gnu/packages/patches/slim-config.patch
new file mode 100644
index 0000000000..5e6135d75c
--- /dev/null
+++ b/gnu/packages/patches/slim-config.patch
@@ -0,0 +1,27 @@
+Allow the configuration file and theme directory to be specified at run time.
+Patch by Eelco Dolstra, from Nixpkgs.
+
+--- slim-1.3.6/app.cpp 2013-10-02 00:38:05.000000000 +0200
++++ slim-1.3.6/app.cpp 2013-10-15 11:02:55.629263422 +0200
+@@ -200,7 +200,9 @@
+
+ /* Read configuration and theme */
+ cfg = new Cfg;
+- cfg->readConf(CFGFILE);
++ char *cfgfile = getenv("SLIM_CFGFILE");
++ if (!cfgfile) cfgfile = CFGFILE;
++ cfg->readConf(cfgfile);
+ string themebase = "";
+ string themefile = "";
+ string themedir = "";
+@@ -208,7 +210,9 @@
+ if (testing) {
+ themeName = testtheme;
+ } else {
+- themebase = string(THEMESDIR) + "/";
++ char *themesdir = getenv("SLIM_THEMESDIR");
++ if (!themesdir) themesdir = THEMESDIR;
++ themebase = string(themesdir) + "/";
+ themeName = cfg->getOption("current_theme");
+ string::size_type pos;
+ if ((pos = themeName.find(",")) != string::npos) {