summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/seed-webkit.patch
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-07-25 09:01:19 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 23:11:16 +0200
commit77d7bbf4bdf75cbbc40c4ac6634b4a3e886a6362 (patch)
treee47e91f180afc67b1c8c69337a8c1a0dfb7c5d1c /gnu/packages/patches/seed-webkit.patch
parentc1082b02873d59f3a0ab3b02cc13e4c444f000cd (diff)
downloadguix-patches-77d7bbf4bdf75cbbc40c4ac6634b4a3e886a6362.tar
guix-patches-77d7bbf4bdf75cbbc40c4ac6634b4a3e886a6362.tar.gz
gnu: Add seed.
* gnu/packages/gnome.scm (seed): New variable. * gnu/packages/patches/seed-webkit.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/patches/seed-webkit.patch')
-rw-r--r--gnu/packages/patches/seed-webkit.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/patches/seed-webkit.patch b/gnu/packages/patches/seed-webkit.patch
new file mode 100644
index 0000000000..55f15af12f
--- /dev/null
+++ b/gnu/packages/patches/seed-webkit.patch
@@ -0,0 +1,49 @@
+From 6d512b5c4d774a9853b51dae464a10cea7e3423a Mon Sep 17 00:00:00 2001
+From: Peter Rustler <peter.rustler@basyskom.com>
+Date: Mon, 7 Dec 2015 11:40:05 +0000
+Subject: [PATCH] Add support for new webkit version 4.0 to build system
+
+Add new configure value for option --with-webkit.
+Now you can add 4.0 as value to --with-webkit.
+Default is still 3.0.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=759171
+---
+ configure.ac | 10 ++++++++--
+ 1 file changed, 8 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 2313c093..3d5d4823 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -77,12 +77,12 @@ dnl ==============================WebKit=======================================
+ m4_define([webkit_default], [3.0])
+
+ AC_ARG_WITH([webkit],
+- [AC_HELP_STRING([--with-webkit=@<:@3.0/1.0@:>@],
++ [AC_HELP_STRING([--with-webkit=@<:@4.0/3.0/1.0@:>@],
+ [Select the Webkit backend, default=3.0])],
+ [],
+ [with_webkit=webkit_default])
+
+-dnl=== support both 1.0 and 3.0 (default 3.0) ==
++dnl=== support all 1.0, 3.0 and 4.0 (default 3.0) ==
+ AS_CASE([$with_webkit],
+ [3.0], [
+ WEBKIT_PC=webkitgtk-3.0
+@@ -90,6 +90,12 @@ AS_CASE([$with_webkit],
+ AC_CHECK_LIB(webkitgtk-3.0, JSContextGroupCreate,,
+ AC_CHECK_LIB(javascriptcoregtk-3.0, JSContextGroupCreate,WEBKIT_PC=javascriptcoregtk-3.0))
+ ],
++ [4.0], [
++ WEBKIT_PC=webkitgtk-4.0
++ SEED_GTK_VERSION=-gtk4
++ AC_CHECK_LIB(webkitgtk-4.0, JSContextGroupCreate,,
++ AC_CHECK_LIB(javascriptcoregtk-4.0, JSContextGroupCreate,WEBKIT_PC=javascriptcoregtk-4.0))
++ ],
+ [1.0], [
+ AC_CHECK_LIB(webkitgtk-1.0, JSContextGroupCreate,WEBKIT_PC=webkitgtk-1.0,
+ AC_CHECK_LIB(javascriptcoregtk-1.0, JSContextGroupCreate,WEBKIT_PC=javascriptcoregtk-1.0,
+--
+GitLab
+