summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/rust-1.25-accept-more-detailed-gdb-lines.patch
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-10-26 18:22:32 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2018-10-30 20:20:55 +0100
commit46cb1c97cb27904b5dea3d153d817130711a2e0a (patch)
tree172e1d022a6f217a943f96e839ee187de639bb70 /gnu/packages/patches/rust-1.25-accept-more-detailed-gdb-lines.patch
parenta6f2afeee185ee28157649cccc1b06ff37fe93df (diff)
downloadguix-patches-46cb1c97cb27904b5dea3d153d817130711a2e0a.tar
guix-patches-46cb1c97cb27904b5dea3d153d817130711a2e0a.tar.gz
gnu: rust: Accept more detailed gdb lines for simple enums.
* gnu/packages/patches/rust-1.25-accept-more-detailed-gdb-lines.patch: Modify. * gnu/packages/rust.scm (rust-1.25)[arguments]<#:phases>[disable-nil-enum-test]: Delete phase.
Diffstat (limited to 'gnu/packages/patches/rust-1.25-accept-more-detailed-gdb-lines.patch')
-rw-r--r--gnu/packages/patches/rust-1.25-accept-more-detailed-gdb-lines.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/rust-1.25-accept-more-detailed-gdb-lines.patch b/gnu/packages/patches/rust-1.25-accept-more-detailed-gdb-lines.patch
index 6ffc897297..f40a12d382 100644
--- a/gnu/packages/patches/rust-1.25-accept-more-detailed-gdb-lines.patch
+++ b/gnu/packages/patches/rust-1.25-accept-more-detailed-gdb-lines.patch
@@ -92,3 +92,19 @@ diff -ur orig/rustc-1.25.0-src/src/test/debuginfo/generic-tuple-style-enum.rs ru
// gdb-command:print univariant
// gdbg-check:$4 = {{__0 = -1}}
+--- orig/rustc-1.25.0-src/src/test/debuginfo/nil-enum.rs 2018-09-13 10:24:33.783565071 +0200
++++ rustc-1.25.0-src/src/test/debuginfo/nil-enum.rs 2018-10-26 18:19:20.404564587 +0200
+@@ -17,11 +17,11 @@
+
+ // gdb-command:print first
+ // gdbg-check:$1 = {<No data fields>}
+-// gdbr-check:$1 = <error reading variable>
++// gdbr-check:$1 = nil_enum::ANilEnum
+
+ // gdb-command:print second
+ // gdbg-check:$2 = {<No data fields>}
+-// gdbr-check:$2 = <error reading variable>
++// gdbr-check:$2 = nil_enum::AnotherNilEnum
+
+ #![allow(unused_variables)]
+ #![feature(omit_gdb_pretty_printer_section)]