summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ripperx-missing-file.patch
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-07-24 21:16:29 +0200
committerAndreas Enge <andreas@enge.fr>2015-07-24 21:16:29 +0200
commitd0dfc06683c868e48ee85213909e4013db94e221 (patch)
treefa12bc2a4bc538acd16b0f81b80708fe443b4c53 /gnu/packages/patches/ripperx-missing-file.patch
parent10b1f68877b8198e0c1ab8b0ae9142f3b00975dd (diff)
downloadguix-patches-d0dfc06683c868e48ee85213909e4013db94e221.tar
guix-patches-d0dfc06683c868e48ee85213909e4013db94e221.tar.gz
gnu: ripperX: Update to 2.8.0.
* gnu/packages/mp3.scm (ripperx): Update to 2.8.0. Drop one patch and add another one. * gnu/packages/patches/ripperx-libm.patch: Remove file. * gnu/packages/patches/ripperx-missing-file.patch: New file. * gnu-system.am (dist_patch_DATA): Register one patch and unregister the other.
Diffstat (limited to 'gnu/packages/patches/ripperx-missing-file.patch')
-rw-r--r--gnu/packages/patches/ripperx-missing-file.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/patches/ripperx-missing-file.patch b/gnu/packages/patches/ripperx-missing-file.patch
new file mode 100644
index 0000000000..6eb197fd7a
--- /dev/null
+++ b/gnu/packages/patches/ripperx-missing-file.patch
@@ -0,0 +1,46 @@
+This patch adds a header file that is present in the ripperx git and needed
+for inclusion, but missing in the distribution tarball.
+
+diff -u -r -N ripperx-2.8.0.orig/src/gtk_cpp_workaround.h ripperx-2.8.0/src/gtk_cpp_workaround.h
+--- ripperx-2.8.0.orig/src/gtk_cpp_workaround.h 1970-01-01 01:00:00.000000000 +0100
++++ ripperx-2.8.0/src/gtk_cpp_workaround.h 2015-07-24 21:09:16.548476337 +0200
+@@ -0,0 +1,39 @@
++#ifndef gtk_cpp_workaround_h
++#define gtk_cpp_workaround_h
++#ifdef __cplusplus
++//proto is wrong, override here for C++
++namespace
++{
++
++inline void gtk_table_attach (GtkTable *table,
++ GtkWidget *child,
++ guint left_attach,
++ guint right_attach,
++ guint top_attach,
++ guint bottom_attach,
++ //GtkAttachOptions xoptions,
++ //GtkAttachOptions yoptions,
++ guint xoptions, guint yoptions,
++ guint xpadding,
++ guint ypadding
++ )
++{
++ gtk_table_attach(table,
++ child,
++ left_attach,
++ right_attach,
++ top_attach,
++ bottom_attach,
++ (GtkAttachOptions)xoptions,
++ (GtkAttachOptions)yoptions,
++ xpadding,
++ ypadding
++ );
++
++ };
++
++
++}
++
++#endif
++#endif