summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-waitress-fix-tests.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-17 20:49:39 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-17 20:49:39 +0100
commit26176bee23706669c7402c8bd083ed29187fe8e9 (patch)
tree0e70111b172743b239c123f3b1b905f804d53785 /gnu/packages/patches/python-waitress-fix-tests.patch
parent9729f9756c6f4b8376fc619b1330b05b8892c21a (diff)
downloadguix-patches-26176bee23706669c7402c8bd083ed29187fe8e9.tar
guix-patches-26176bee23706669c7402c8bd083ed29187fe8e9.tar.gz
gnu: python-waitress: Update to 1.1.0.
* gnu/packages/patches/python-waitress-fix-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/python.scm (python-waitress): Update to 1.1.0. [source](patches): New field.
Diffstat (limited to 'gnu/packages/patches/python-waitress-fix-tests.patch')
-rw-r--r--gnu/packages/patches/python-waitress-fix-tests.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-waitress-fix-tests.patch b/gnu/packages/patches/python-waitress-fix-tests.patch
new file mode 100644
index 0000000000..110492a604
--- /dev/null
+++ b/gnu/packages/patches/python-waitress-fix-tests.patch
@@ -0,0 +1,29 @@
+Skip test that requires getaddrinfo(), which is not available in the build
+environment. This package uses a regexp for finding tests (see runner.py),
+so using @unittest.skip does not work.
+
+--- a/waitress/tests/test_adjustments.py
++++ b/waitress/tests/test_adjustments.py
+@@ -185,22 +185,6 @@
+ def test_bad_port(self):
+ self.assertRaises(ValueError, self._makeOne, listen='127.0.0.1:test')
+
+- def test_service_port(self):
+- if WIN and PY2: # pragma: no cover
+- # On Windows and Python 2 this is broken, so we raise a ValueError
+- self.assertRaises(
+- ValueError,
+- self._makeOne,
+- listen='127.0.0.1:http',
+- )
+- return
+-
+- inst = self._makeOne(listen='127.0.0.1:http 0.0.0.0:https')
+-
+- bind_pairs = [sockaddr[:2] for (_, _, _, sockaddr) in inst.listen]
+-
+- self.assertEqual(bind_pairs, [('127.0.0.1', 80), ('0.0.0.0', 443)])
+-
+ def test_dont_mix_host_port_listen(self):
+ self.assertRaises(
+ ValueError,