summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-slugify-depend-on-unidecode.patch
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2019-06-12 21:15:27 +0100
committerLudovic Courtès <ludo@gnu.org>2019-07-07 15:48:19 +0200
commit6543bc80b41c488a069b39d8b26e6d61cbb8252d (patch)
treea1ae82c8d976056c20aac2397198946766b2dccc /gnu/packages/patches/python-slugify-depend-on-unidecode.patch
parente41ba8606f13513c89832cdfffbafc689740f8bc (diff)
downloadguix-patches-6543bc80b41c488a069b39d8b26e6d61cbb8252d.tar
guix-patches-6543bc80b41c488a069b39d8b26e6d61cbb8252d.tar.gz
gnu: Add python-slugify.
* gnu/packages/python-web.scm (python-slugify): New variable. * gnu/packages/patches/python-slugify-depend-on-unidecode.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/python-slugify-depend-on-unidecode.patch')
-rw-r--r--gnu/packages/patches/python-slugify-depend-on-unidecode.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-slugify-depend-on-unidecode.patch b/gnu/packages/patches/python-slugify-depend-on-unidecode.patch
new file mode 100644
index 0000000000..6038f432f1
--- /dev/null
+++ b/gnu/packages/patches/python-slugify-depend-on-unidecode.patch
@@ -0,0 +1,22 @@
+diff --git a/setup.py b/setup.py
+index 4800173..6bdd77f 100755
+--- a/setup.py
++++ b/setup.py
+@@ -14,8 +14,7 @@ url = 'https://github.com/un33k/python-slugify'
+ author = 'Val Neekman'
+ author_email = 'info@neekware.com'
+ license = 'MIT'
+-install_requires = ['text-unidecode==1.2']
+-extras_require = {'unidecode': ['Unidecode==1.0.23']}
++install_requires = ['Unidecode']
+
+ classifiers = [
+ 'Development Status :: 5 - Production/Stable',
+@@ -67,7 +66,6 @@ setup(
+ author_email=author_email,
+ packages=find_packages(exclude=EXCLUDE_FROM_PACKAGES),
+ install_requires=install_requires,
+- extras_require=extras_require,
+ classifiers=classifiers,
+ entry_points={'console_scripts': ['slugify=slugify.slugify:main']},
+ )