summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-packaging-test-arch.patch
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-11-30 10:48:57 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-30 22:04:13 +0100
commit71b15b4874b7f9ec7001d2916a8ab27dcce6cdc0 (patch)
treeaf75d5124cc7e8ef3e5687e46ea88dafab60459a /gnu/packages/patches/python-packaging-test-arch.patch
parent265e1858fb730bdc57c2059127109520bb2fc3cb (diff)
downloadguix-patches-71b15b4874b7f9ec7001d2916a8ab27dcce6cdc0.tar
guix-patches-71b15b4874b7f9ec7001d2916a8ab27dcce6cdc0.tar.gz
gnu: python-packaging: Update to 20.4.
* gnu/packages/python-xyz.scm (python-packaging): Update to 20.4. [source]: Remove patch that has been merged upstream. * gnu/packages/patches/python-packaging-test-arch.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Apply removal. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/patches/python-packaging-test-arch.patch')
-rw-r--r--gnu/packages/patches/python-packaging-test-arch.patch65
1 files changed, 0 insertions, 65 deletions
diff --git a/gnu/packages/patches/python-packaging-test-arch.patch b/gnu/packages/patches/python-packaging-test-arch.patch
deleted file mode 100644
index df80a62544..0000000000
--- a/gnu/packages/patches/python-packaging-test-arch.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-Fix tests that are "hard coded" to expect x86_64 output by mocking the platform interface.
-
-Submitted upstream:
-https://github.com/pypa/packaging/pull/176
-
-diff --git a/tests/test_tags.py b/tests/test_tags.py
-index 1eacf68..0a3f1b4 100644
---- a/tests/test_tags.py
-+++ b/tests/test_tags.py
-@@ -435,37 +435,43 @@ class TestManylinuxPlatform:
- linux_platform = list(tags._linux_platforms(is_32bit=False))
- assert linux_platform == ["linux_x86_64"]
-
-- def test_linux_platforms_manylinux1(self, monkeypatch):
-+ def test_linux_platforms_manylinux1(self, is_x86, monkeypatch):
- monkeypatch.setattr(
- tags, "_is_manylinux_compatible", lambda name, _: name == "manylinux1"
- )
-- if platform.system() != "Linux":
-+ if platform.system() != "Linux" or not is_x86:
- monkeypatch.setattr(distutils.util, "get_platform", lambda: "linux_x86_64")
-+ monkeypatch.setattr(platform, "machine", lambda: "x86_64")
- platforms = list(tags._linux_platforms(is_32bit=False))
-- assert platforms == ["manylinux1_x86_64", "linux_x86_64"]
-+ arch = platform.machine()
-+ assert platforms == ["manylinux1_" + arch, "linux_" + arch]
-
-- def test_linux_platforms_manylinux2010(self, monkeypatch):
-+ def test_linux_platforms_manylinux2010(self, is_x86, monkeypatch):
- monkeypatch.setattr(
- tags, "_is_manylinux_compatible", lambda name, _: name == "manylinux2010"
- )
-- if platform.system() != "Linux":
-+ if platform.system() != "Linux" or not is_x86:
- monkeypatch.setattr(distutils.util, "get_platform", lambda: "linux_x86_64")
-+ monkeypatch.setattr(platform, "machine", lambda: "x86_64")
- platforms = list(tags._linux_platforms(is_32bit=False))
-- expected = ["manylinux2010_x86_64", "manylinux1_x86_64", "linux_x86_64"]
-+ arch = platform.machine()
-+ expected = ["manylinux2010_" + arch, "manylinux1_" + arch, "linux_" + arch]
- assert platforms == expected
-
-- def test_linux_platforms_manylinux2014(self, monkeypatch):
-+ def test_linux_platforms_manylinux2014(self, is_x86, monkeypatch):
- monkeypatch.setattr(
- tags, "_is_manylinux_compatible", lambda name, _: name == "manylinux2014"
- )
-- if platform.system() != "Linux":
-+ if platform.system() != "Linux" or not is_x86:
- monkeypatch.setattr(distutils.util, "get_platform", lambda: "linux_x86_64")
-+ monkeypatch.setattr(platform, "machine", lambda: "x86_64")
- platforms = list(tags._linux_platforms(is_32bit=False))
-+ arch = platform.machine()
- expected = [
-- "manylinux2014_x86_64",
-- "manylinux2010_x86_64",
-- "manylinux1_x86_64",
-- "linux_x86_64",
-+ "manylinux2014_" + arch,
-+ "manylinux2010_" + arch,
-+ "manylinux1_" + arch,
-+ "linux_" + arch,
- ]
- assert platforms == expected
-