summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-3.8-search-paths.patch
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2019-11-19 09:50:51 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-11-20 00:16:51 +0100
commitaf6a9fc27622ea8a342fe18c8604f2fe64a04e68 (patch)
tree480934e5a9d67309df923b1fbe20e82a4afe0de2 /gnu/packages/patches/python-3.8-search-paths.patch
parent3b7828cc7f938fcb369976cbe75d9c85f22583a1 (diff)
downloadguix-patches-af6a9fc27622ea8a342fe18c8604f2fe64a04e68.tar
guix-patches-af6a9fc27622ea8a342fe18c8604f2fe64a04e68.tar.gz
gnu: Add python-3.8.
* gnu/packages/python.scm (python-3.8): New public variable. [source]: Add patches to skip four tests. * gnu/packages/patches/python-3.8-search-paths.patch: New file. * gnu/packages/patches/python-3.8-fix-tests.patch: New file. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/patches/python-3.8-search-paths.patch')
-rw-r--r--gnu/packages/patches/python-3.8-search-paths.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-3.8-search-paths.patch b/gnu/packages/patches/python-3.8-search-paths.patch
new file mode 100644
index 0000000000..88f19850bf
--- /dev/null
+++ b/gnu/packages/patches/python-3.8-search-paths.patch
@@ -0,0 +1,17 @@
+diff --git a/setup.py b/setup.py
+index 20d7f35..5751083 100644
+--- a/setup.py
++++ b/setup.py
+@@ -676,8 +676,8 @@ class PyBuildExt(build_ext):
+ # if a file is found in one of those directories, it can
+ # be assumed that no additional -I,-L directives are needed.
+ if not CROSS_COMPILING:
+- self.lib_dirs = self.compiler.library_dirs + system_lib_dirs
+- self.inc_dirs = self.compiler.include_dirs + system_include_dirs
++ self.lib_dirs = os.getenv('LIBRARY_PATH', '').split(os.pathsep)
++ self.inc_dirs = os.getenv('CPATH', '').split(os.pathsep)
+ else:
+ # Add the sysroot paths. 'sysroot' is a compiler option used to
+ # set the logical path of the standard system headers and
+--
+2.23.0