summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-3-search-paths.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-01-05 12:35:30 +0100
committerLudovic Courtès <ludo@gnu.org>2016-01-05 13:13:17 +0100
commita2ab82db9ab5d6db86762924d3016aed7c26c315 (patch)
tree4ecacd3bc18bd62055363c43f2d6907d6e8e67c7 /gnu/packages/patches/python-3-search-paths.patch
parent4f2ca234934983544de73758b6badb61c047f805 (diff)
downloadguix-patches-a2ab82db9ab5d6db86762924d3016aed7c26c315.tar
guix-patches-a2ab82db9ab5d6db86762924d3016aed7c26c315.tar.gz
gnu: python: Honor 'C_INCLUDE_PATH'.
This is a followup to 009b53fd. * gnu/packages/patches/python-3-search-paths.patch: Check 'C_INCLUDE_PATH' instead of 'CPATH'. * gnu/packages/patches/python-2.7-search-paths.patch: Likewise.
Diffstat (limited to 'gnu/packages/patches/python-3-search-paths.patch')
-rw-r--r--gnu/packages/patches/python-3-search-paths.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/patches/python-3-search-paths.patch b/gnu/packages/patches/python-3-search-paths.patch
index 547feae1b9..7feddb8e30 100644
--- a/gnu/packages/patches/python-3-search-paths.patch
+++ b/gnu/packages/patches/python-3-search-paths.patch
@@ -1,5 +1,5 @@
-Make sure the build system honors CPATH and LIBRARY_PATH when looking for
-headers and libraries.
+Make sure the build system honors C_INCLUDE_PATH and LIBRARY_PATH when
+looking for headers and libraries.
--- setup.py 2015-10-07 23:32:58.891329173 +0200
+++ setup.py 2015-10-07 23:46:29.653349924 +0200
@@ -13,7 +13,7 @@ headers and libraries.
- ]
- inc_dirs = self.compiler.include_dirs + ['/usr/include']
+ lib_dirs = os.getenv('LIBRARY_PATH', '').split(os.pathsep)
-+ inc_dirs = os.getenv('CPATH', '').split(os.pathsep)
++ inc_dirs = os.getenv('C_INCLUDE_PATH', '').split(os.pathsep)
else:
lib_dirs = self.compiler.library_dirs[:]
inc_dirs = self.compiler.include_dirs[:]