summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-3-search-paths.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-15 15:26:20 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-03-15 17:20:57 +0100
commit5c798ca71dcd009896654da7d6a1f8942c6f3c50 (patch)
treec86cc60b0d265d723daa8535370f5df26623cedc /gnu/packages/patches/python-3-search-paths.patch
parent4403030b7de2485dbeb6ee54c56551a2bd2b5244 (diff)
downloadguix-patches-5c798ca71dcd009896654da7d6a1f8942c6f3c50.tar
guix-patches-5c798ca71dcd009896654da7d6a1f8942c6f3c50.tar.gz
gnu: python: Update to 3.6.4.
* gnu/packages/patches/python-3-search-paths.patch: Adjust context. * gnu/packages/python.scm (python): Update to 3.6.4. [source]: Re-enable test_socket.py.
Diffstat (limited to 'gnu/packages/patches/python-3-search-paths.patch')
-rw-r--r--gnu/packages/patches/python-3-search-paths.patch13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/patches/python-3-search-paths.patch b/gnu/packages/patches/python-3-search-paths.patch
index 7feddb8e30..73e3f4ccf5 100644
--- a/gnu/packages/patches/python-3-search-paths.patch
+++ b/gnu/packages/patches/python-3-search-paths.patch
@@ -3,17 +3,14 @@ looking for headers and libraries.
--- setup.py 2015-10-07 23:32:58.891329173 +0200
+++ setup.py 2015-10-07 23:46:29.653349924 +0200
-@@ -507,11 +507,8 @@ class PyBuildExt(build_ext):
+@@ -575,8 +575,8 @@
# if a file is found in one of those directories, it can
# be assumed that no additional -I,-L directives are needed.
if not cross_compiling:
-- lib_dirs = self.compiler.library_dirs + [
-- '/lib64', '/usr/lib64',
-- '/lib', '/usr/lib',
-- ]
-- inc_dirs = self.compiler.include_dirs + ['/usr/include']
+- lib_dirs = self.compiler.library_dirs + system_lib_dirs
+- inc_dirs = self.compiler.include_dirs + system_include_dirs
+ lib_dirs = os.getenv('LIBRARY_PATH', '').split(os.pathsep)
+ inc_dirs = os.getenv('C_INCLUDE_PATH', '').split(os.pathsep)
else:
- lib_dirs = self.compiler.library_dirs[:]
- inc_dirs = self.compiler.include_dirs[:]
+ # Add the sysroot paths. 'sysroot' is a compiler option used to
+ # set the logical path of the standard system headers and