summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-2.7-search-paths.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-10-05 20:46:57 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-02-09 21:53:41 +0100
commita1635de0ce12979d74ba3796d460c01e58b198f3 (patch)
tree1dde7fba113a55878e2607142c3af0eb122e6302 /gnu/packages/patches/python-2.7-search-paths.patch
parent3670ea70e2e932969a3ffc0acf75a714c7b42540 (diff)
downloadguix-patches-a1635de0ce12979d74ba3796d460c01e58b198f3.tar
guix-patches-a1635de0ce12979d74ba3796d460c01e58b198f3.tar.gz
gnu: python: Fix FTBFS with GCC >= 6.
* gnu/packages/patches/python-3-search-paths.patch: s/C_INCLUDE_PATH/CPATH. * gnu/packages/patches/python-2.7-search-paths.patch: Ditto.
Diffstat (limited to 'gnu/packages/patches/python-2.7-search-paths.patch')
-rw-r--r--gnu/packages/patches/python-2.7-search-paths.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/patches/python-2.7-search-paths.patch b/gnu/packages/patches/python-2.7-search-paths.patch
index ba7235df27..a012bc8fe0 100644
--- a/gnu/packages/patches/python-2.7-search-paths.patch
+++ b/gnu/packages/patches/python-2.7-search-paths.patch
@@ -1,4 +1,4 @@
-Make sure the build system honors C_INCLUDE_PATH and LIBRARY_PATH when
+Make sure the build system honors CPATH and LIBRARY_PATH when
looking for headers and libraries.
--- Python-2.7.10/setup.py 2015-10-07 18:33:18.125153186 +0200
@@ -9,7 +9,7 @@ looking for headers and libraries.
+ # Always honor these variables.
+ lib_dirs += os.getenv('LIBRARY_PATH', '').split(os.pathsep)
-+ inc_dirs += os.getenv('C_INCLUDE_PATH', '').split(os.pathsep)
++ inc_dirs += os.getenv('CPATH', '').split(os.pathsep)
+
# OSF/1 and Unixware have some stuff in /usr/ccs/lib (like -ldb)
if host_platform in ['osf1', 'unixware7', 'openunix8']: