summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-2.7-adjust-tests.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-10-04 21:48:05 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-19 00:16:49 +0200
commit603a64920f13a28a5b62cb8aedf1f460f08e15f0 (patch)
tree42ddf966b9bc1af85c91faa09fce666d003c9b8e /gnu/packages/patches/python-2.7-adjust-tests.patch
parent9d8796a5169238f00705bbda8885667a24219388 (diff)
downloadguix-patches-603a64920f13a28a5b62cb8aedf1f460f08e15f0.tar
guix-patches-603a64920f13a28a5b62cb8aedf1f460f08e15f0.tar.gz
gnu: python@2: Update to 2.7.14.
* gnu/packages/python.scm (python-2.7): Update to 2.7.14. [source]: Add patch to skip two new tests. Delete upstreamed patch. * gnu/packages/patches/python-2.7-adjust-tests.patch: New file. * gnu/packages/patches/python-2.7-getentropy-on-old-kernels.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/patches/python-2.7-adjust-tests.patch')
-rw-r--r--gnu/packages/patches/python-2.7-adjust-tests.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-2.7-adjust-tests.patch b/gnu/packages/patches/python-2.7-adjust-tests.patch
new file mode 100644
index 0000000000..12fe6e2e1e
--- /dev/null
+++ b/gnu/packages/patches/python-2.7-adjust-tests.patch
@@ -0,0 +1,22 @@
+SIGINT is ignored in the Guix build environment.
+
+--- a/Lib/test/test_regrtest.py
++++ b/Lib/test/test_regrtest.py
+@@ -399,6 +399,8 @@
+ output = self.run_tests('--fromfile', filename)
+ self.check_executed_tests(output, tests)
+
++ @unittest.skipIf(True,
++ "KeyboardInterrupts do not work in the build environment")
+ def test_interrupted(self):
+ code = TEST_INTERRUPTED
+ test = self.create_test('sigint', code=code)
+@@ -416,6 +418,8 @@
+ % (self.TESTNAME_REGEX, len(tests)))
+ self.check_line(output, regex)
+
++ @unittest.skipIf(True,
++ "KeyboardInterrupts do not work in the build environment")
+ def test_slow_interrupted(self):
+ # Issue #25373: test --slowest with an interrupted test
+ code = TEST_INTERRUPTED