summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/pyqt-configure.patch
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-01-25 20:07:08 +0100
committerAndreas Enge <andreas@enge.fr>2015-01-25 20:10:03 +0100
commit014e7dd8f0d5add1a1aa234399c499099a2b2885 (patch)
tree7c689c77298c743a4129f7c46fc232a68ce95b44 /gnu/packages/patches/pyqt-configure.patch
parent84ef83dd05b829264c924d37782f7d74bec43718 (diff)
downloadguix-patches-014e7dd8f0d5add1a1aa234399c499099a2b2885.tar
guix-patches-014e7dd8f0d5add1a1aa234399c499099a2b2885.tar.gz
gnu: Add python-pyqt.
* gnu/packages/qt.scm (python-pyqt, python2-pyqt): New variables. * gnu/packages/patches/pyqt-configure.patch: New file. * gnu-system.am (dist_patch_DATA): Register patch.
Diffstat (limited to 'gnu/packages/patches/pyqt-configure.patch')
-rw-r--r--gnu/packages/patches/pyqt-configure.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/pyqt-configure.patch b/gnu/packages/patches/pyqt-configure.patch
new file mode 100644
index 0000000000..b922f108d8
--- /dev/null
+++ b/gnu/packages/patches/pyqt-configure.patch
@@ -0,0 +1,15 @@
+Have configure.py modify internal variables depending on the --qml-plugindir
+configure option.
+diff -u PyQt-gpl-5.4.alt/configure.py PyQt-gpl-5.4/configure.py
+--- PyQt-gpl-5.4.alt/configure.py 2015-01-25 17:27:50.000000000 +0100
++++ PyQt-gpl-5.4/configure.py 2015-01-25 17:56:41.000000000 +0100
+@@ -904,6 +904,9 @@
+ if opts.pyuicinterpreter is not None:
+ self.pyuic_interpreter = opts.pyuicinterpreter
+
++ if opts.qmlplugindir is not None:
++ self.qml_plugin_dir = opts.qmlplugindir
++
+ if opts.qsciapidir is not None:
+ self.qsci_api_dir = opts.qsciapidir
+