summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/pjproject-install-libpjsua2.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-12 15:25:22 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-13 00:57:52 -0500
commitf787ccca42f1b8acb347892246fc36bc44392712 (patch)
tree0e24235a0fed73235558b87122061df5a5e264b7 /gnu/packages/patches/pjproject-install-libpjsua2.patch
parent7d6afde74c8668751a8163d8356e52eb207a2193 (diff)
downloadguix-patches-f787ccca42f1b8acb347892246fc36bc44392712.tar
guix-patches-f787ccca42f1b8acb347892246fc36bc44392712.tar.gz
gnu: pjproject: Apply patch to install the libpjsua2 shared library.
* gnu/packages/patches/pjproject-install-libpjsua2.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/telephony.scm (pjproject): Apply it.
Diffstat (limited to 'gnu/packages/patches/pjproject-install-libpjsua2.patch')
-rw-r--r--gnu/packages/patches/pjproject-install-libpjsua2.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/patches/pjproject-install-libpjsua2.patch b/gnu/packages/patches/pjproject-install-libpjsua2.patch
new file mode 100644
index 0000000000..ef9b0de91f
--- /dev/null
+++ b/gnu/packages/patches/pjproject-install-libpjsua2.patch
@@ -0,0 +1,19 @@
+# Retrieved from upstream:
+# https://github.com/pjsip/pjproject/commit/742f7dc252ded778a8b677937791c02e2fbc0dde
+diff --git a/Makefile b/Makefile
+index 31a6d39d4..74e246a44 100644
+--- a/Makefile
++++ b/Makefile
+@@ -121,9 +121,10 @@ cmp_wav:
+
+ install:
+ mkdir -p $(DESTDIR)$(libdir)/
+- cp -af $(APP_LIB_FILES) $(DESTDIR)$(libdir)/
+ if [ "$(PJ_EXCLUDE_PJSUA2)x" = "x" ] ; then \
+- cp -af $(PJ_DIR)/pjsip/lib/libpjsua2-$(LIB_SUFFIX) $(DESTDIR)$(libdir)/; \
++ cp -af $(APP_LIBXX_FILES) $(DESTDIR)$(libdir)/; \
++ else \
++ cp -af $(APP_LIB_FILES) $(DESTDIR)$(libdir)/; \
+ fi
+ mkdir -p $(DESTDIR)$(includedir)/
+ for d in pjlib pjlib-util pjnath pjmedia pjsip; do \