summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/perl-reproducible-build-date.patch
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-08-16 17:58:09 -0400
committerLeo Famulari <leo@famulari.name>2016-08-17 22:55:15 -0400
commita3d6e1f432ad5f9cde8bee670b28646e05c4cb19 (patch)
treee4416208cdcd0ab0df8167153dd26cc0142fceb0 /gnu/packages/patches/perl-reproducible-build-date.patch
parent9bb1826651cf62cef4448b3bf4d9e55da3a0a8d8 (diff)
downloadguix-patches-a3d6e1f432ad5f9cde8bee670b28646e05c4cb19.tar
guix-patches-a3d6e1f432ad5f9cde8bee670b28646e05c4cb19.tar.gz
gnu: perl: Update to 5.24.0.
* gnu/packages/perl.scm: Update to 5.24.0. [source]: Add and remove patches. * gnu/packages/patches/perl-reproducible-build-date.patch: New file. * gnu/packages/patches/perl-CVE-2015-8607.patch, gnu/packages/patches/perl-CVE-2016-2381.patch, gnu/packages/patches/perl-no-build-time.patch, gnu/packages/patches/perl-source-date-epoch.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Add and remove patches.
Diffstat (limited to 'gnu/packages/patches/perl-reproducible-build-date.patch')
-rw-r--r--gnu/packages/patches/perl-reproducible-build-date.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/perl-reproducible-build-date.patch b/gnu/packages/patches/perl-reproducible-build-date.patch
new file mode 100644
index 0000000000..d5bd25dbfb
--- /dev/null
+++ b/gnu/packages/patches/perl-reproducible-build-date.patch
@@ -0,0 +1,17 @@
+Don't encode the current timestamp.
+
+This affects the output of `perl -V`, specifically the message "Compiled
+at [...]".
+
+diff --git a/perl.c b/perl.c
+index 228a0d8..ed38313 100644
+--- a/perl.c
++++ b/perl.c
+@@ -1825,6 +1825,7 @@ S_Internals_V(pTHX_ CV *cv)
+ PUSHs(Perl_newSVpvn_flags(aTHX_ non_bincompat_options,
+ sizeof(non_bincompat_options) - 1, SVs_TEMP));
+
++#define PERL_BUILD_DATE "Jan 1 1970 00:00:00"
+ #ifndef PERL_BUILD_DATE
+ # ifdef __DATE__
+ # ifdef __TIME__