summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/perl-no-sys-dirs.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-23 18:14:01 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-25 00:47:53 +0200
commita3e53041b87932e2a44b109d7f28cc331bc5021b (patch)
tree9690675fd2f156c0491e532fdda9bdf04085639e /gnu/packages/patches/perl-no-sys-dirs.patch
parent1b4c3faff4a412e8478184bc7b41fa23c78c4320 (diff)
downloadguix-patches-a3e53041b87932e2a44b109d7f28cc331bc5021b.tar
guix-patches-a3e53041b87932e2a44b109d7f28cc331bc5021b.tar.gz
gnu: perl: Update to 5.30.0.
* gnu/packages/patches/perl-no-sys-dirs.patch: Adjust Errno.h hunk. * gnu/packages/perl.scm (perl): Update to 5.30.0.
Diffstat (limited to 'gnu/packages/patches/perl-no-sys-dirs.patch')
-rw-r--r--gnu/packages/patches/perl-no-sys-dirs.patch23
1 files changed, 16 insertions, 7 deletions
diff --git a/gnu/packages/patches/perl-no-sys-dirs.patch b/gnu/packages/patches/perl-no-sys-dirs.patch
index 31d53e0353..2269d715c7 100644
--- a/gnu/packages/patches/perl-no-sys-dirs.patch
+++ b/gnu/packages/patches/perl-no-sys-dirs.patch
@@ -112,20 +112,29 @@ Only in perl-5.20.0/: Configure.orig
diff -ru -x '*~' -x '*.rej' perl-5.20.0-orig/ext/Errno/Errno_pm.PL perl-5.20.0/ext/Errno/Errno_pm.PL
--- perl-5.20.0-orig/ext/Errno/Errno_pm.PL 2014-05-26 15:34:20.000000000 +0200
+++ perl-5.20.0/ext/Errno/Errno_pm.PL 2014-06-25 10:31:24.317970047 +0200
-@@ -126,11 +126,7 @@
+@@ -114,7 +114,7 @@ sub get_files {
+ # When cross-compiling we may store a path for gcc's "sysroot" option:
+ my $sysroot = $Config{sysroot} || '';
+ my $linux_errno_h;
+- if ($^O eq 'linux') {
++ if (0) {
+ # Some Linuxes have weird errno.hs which generate
+ # no #file or #line directives
+ ($linux_errno_h) = grep { -e $_ } map { "$_/errno.h" }
+@@ -134,13 +134,6 @@ sub get_files {
if ($dep =~ /(\S+errno\.h)/) {
$file{$1} = 1;
}
- } elsif ($^O eq 'linux' &&
- $Config{gccversion} ne '' &&
-- $Config{gccversion} !~ /intel/i
+- $Config{gccversion} !~ /intel/i &&
- # might be using, say, Intel's icc
+- $linux_errno_h
- ) {
-+ } elsif (0) {
- # When cross-compiling we may store a path for gcc's "sysroot" option:
- my $sysroot = $Config{sysroot} || '';
- # Some Linuxes have weird errno.hs which generate
-Only in perl-5.20.0/ext/Errno: Errno_pm.PL.orig
+- $file{$linux_errno_h} = 1;
+ } elsif ($^O eq 'haiku') {
+ # hidden in a special place
+ $file{'/boot/develop/headers/posix/errno.h'} = 1;
diff -ru -x '*~' -x '*.rej' perl-5.20.0-orig/hints/freebsd.sh perl-5.20.0/hints/freebsd.sh
--- perl-5.20.0-orig/hints/freebsd.sh 2014-01-31 22:55:51.000000000 +0100
+++ perl-5.20.0/hints/freebsd.sh 2014-06-25 10:25:53.263964680 +0200