summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/perl-5.14-module-pluggable-search.patch
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-01-28 18:34:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-02-07 14:02:15 +0100
commit013086c3dbaa2e28dd1b3c21a7ebe51ac829a1eb (patch)
treef7fb6a850048b806d40183c3deea8eed638c85c5 /gnu/packages/patches/perl-5.14-module-pluggable-search.patch
parent26d9e6c9043e8dd6a40498b1d7fbeedf6e134d6d (diff)
downloadguix-patches-013086c3dbaa2e28dd1b3c21a7ebe51ac829a1eb.tar
guix-patches-013086c3dbaa2e28dd1b3c21a7ebe51ac829a1eb.tar.gz
gnu: Add perl-5.14.
* gnu/packages/patches/perl-5.14-autosplit-default-time.patch, gnu/packages/patches/perl-5.14-module-pluggable-search.patch, gnu/packages/patches/perl-5.14-no-sys-dirs.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/perl.scm (perl-5.14): New variable.
Diffstat (limited to 'gnu/packages/patches/perl-5.14-module-pluggable-search.patch')
-rw-r--r--gnu/packages/patches/perl-5.14-module-pluggable-search.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/patches/perl-5.14-module-pluggable-search.patch b/gnu/packages/patches/perl-5.14-module-pluggable-search.patch
new file mode 100644
index 0000000000..bb2a57f7e5
--- /dev/null
+++ b/gnu/packages/patches/perl-5.14-module-pluggable-search.patch
@@ -0,0 +1,25 @@
+Fix core Perl module Module::Pluggable such that it can find plugins that live
+in symlinked directories.
+
+Patch borrowed/adapted from Nixpkgs.
+
+--- perl-5.16.1/cpan/Module-Pluggable/lib/Module/Pluggable/Object.pm 2015-04-08 23:28:48.120164135 -0500
++++ perl-5.16.1/cpan/Module-Pluggable/lib/Module/Pluggable/Object.pm 2015-04-08 23:30:27.032166704 -0500
+@@ -164,7 +164,7 @@
+ my $sp = catdir($dir, (split /::/, $searchpath));
+
+ # if it doesn't exist or it's not a dir then skip it
+- next unless ( -e $sp && -d _ ); # Use the cached stat the second time
++ next unless ( -e $sp );
+
+ my @files = $self->find_files($sp);
+
+@@ -279,7 +279,7 @@
+ (my $path = $File::Find::name) =~ s#^\\./##;
+ push @files, $path;
+ }
+- }, $search_path );
++ }, "$search_path/." );
+ }
+ #chdir $cwd;
+ return @files;