summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/p7zip-CVE-2017-17969.patch
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-02-05 16:21:12 -0500
committerLeo Famulari <leo@famulari.name>2018-02-05 16:21:40 -0500
commita630c64709af2ab7fdeb797ee35d89964b1fc042 (patch)
tree7d945e7be37b4bdfdf510505e283ab7fbcec9bf3 /gnu/packages/patches/p7zip-CVE-2017-17969.patch
parentb1968d86b9bc838d95be4745f53c63493920ae3a (diff)
downloadguix-patches-a630c64709af2ab7fdeb797ee35d89964b1fc042.tar
guix-patches-a630c64709af2ab7fdeb797ee35d89964b1fc042.tar.gz
gnu: p7zip: Fix CVE-2017-17969.
* gnu/packages/patches/p7zip-CVE-2017-17969.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/compression.scm (p7zip)[source]: Use it.
Diffstat (limited to 'gnu/packages/patches/p7zip-CVE-2017-17969.patch')
-rw-r--r--gnu/packages/patches/p7zip-CVE-2017-17969.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/patches/p7zip-CVE-2017-17969.patch b/gnu/packages/patches/p7zip-CVE-2017-17969.patch
new file mode 100644
index 0000000000..51c24000e5
--- /dev/null
+++ b/gnu/packages/patches/p7zip-CVE-2017-17969.patch
@@ -0,0 +1,35 @@
+Fix CVE-2017-17969:
+
+https://sourceforge.net/p/p7zip/bugs/204/
+https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-17969
+
+Patch copied from Debian.
+
+Subject: Heap-based buffer overflow in 7zip/Compress/ShrinkDecoder.cpp
+Origin: vendor, https://sourceforge.net/p/p7zip/bugs/_discuss/thread/0920f369/27d7/attachment/CVE-2017-17969.patch
+Forwarded: https://sourceforge.net/p/p7zip/bugs/_discuss/thread/0920f369/#27d7
+Bug: https://sourceforge.net/p/p7zip/bugs/204/
+Bug-Debian: https://bugs.debian.org/888297
+Bug-Debian-Security: https://security-tracker.debian.org/tracker/CVE-2017-17969
+Author: Antoine Beaupré <anarcat@debian.org>
+Reviewed-by: Salvatore Bonaccorso <carnil@debian.org>
+Last-Update: 2018-02-01
+Applied-Upstream: 18.00-beta
+
+--- a/CPP/7zip/Compress/ShrinkDecoder.cpp
++++ b/CPP/7zip/Compress/ShrinkDecoder.cpp
+@@ -121,8 +121,13 @@ HRESULT CDecoder::CodeReal(ISequentialIn
+ {
+ _stack[i++] = _suffixes[cur];
+ cur = _parents[cur];
++ if (cur >= kNumItems || i >= kNumItems)
++ break;
+ }
+-
++
++ if (cur >= kNumItems || i >= kNumItems)
++ break;
++
+ _stack[i++] = (Byte)cur;
+ lastChar2 = (Byte)cur;
+