summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/nss-increase-test-timeout.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-03-14 22:54:41 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-03-15 17:56:05 +0100
commitd027b0011f2dec1c6568381deeb817933fd131a9 (patch)
treec6c83b59bd60fa6fe3e3225452fc83a3a766ea3a /gnu/packages/patches/nss-increase-test-timeout.patch
parent1461dd241000b44f03733fe9fd2f13ba4463ed28 (diff)
downloadguix-patches-d027b0011f2dec1c6568381deeb817933fd131a9.tar
guix-patches-d027b0011f2dec1c6568381deeb817933fd131a9.tar.gz
gnu: nss: Increase test timeouts.
* gnu/packages/patches/nss-increase-test-timeout.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gnuzilla.scm (nss)[source]: Use it.
Diffstat (limited to 'gnu/packages/patches/nss-increase-test-timeout.patch')
-rw-r--r--gnu/packages/patches/nss-increase-test-timeout.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/patches/nss-increase-test-timeout.patch b/gnu/packages/patches/nss-increase-test-timeout.patch
new file mode 100644
index 0000000000..c6aac6ac00
--- /dev/null
+++ b/gnu/packages/patches/nss-increase-test-timeout.patch
@@ -0,0 +1,25 @@
+We've seen some tests take more than 20s to complete on a busy armhf
+machine. Even a busy x86_64 machine can use more than 5s on some tests.
+
+Increase timeouts to increase chances of a successful build.
+
+--- a/nss/gtests/ssl_gtest/tls_connect.cc 2017-03-14 22:47:30.855813629 +0100
++++ b/nss/gtests/ssl_gtest/tls_connect.cc 2017-03-14 22:48:49.042335273 +0100
+@@ -245,7 +245,7 @@
+
+ ASSERT_TRUE_WAIT((client_->state() != TlsAgent::STATE_CONNECTING) &&
+ (server_->state() != TlsAgent::STATE_CONNECTING),
+- 5000);
++ 25000);
+ }
+
+ void TlsConnectTestBase::EnableExtendedMasterSecret() {
+@@ -387,7 +387,7 @@
+ } else {
+ fail_agent = server_;
+ }
+- ASSERT_TRUE_WAIT(fail_agent->state() == TlsAgent::STATE_ERROR, 5000);
++ ASSERT_TRUE_WAIT(fail_agent->state() == TlsAgent::STATE_ERROR, 25000);
+ }
+
+ void TlsConnectTestBase::ConfigureVersion(uint16_t version) {