summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/nss-increase-test-timeout.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-04-16 21:21:36 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-04-16 21:23:51 +0200
commita790f262074c94f6b7acb118fb22981d71f1722f (patch)
tree811cbe3d84d7cd70549d287232cd55f1aeb73b05 /gnu/packages/patches/nss-increase-test-timeout.patch
parenta7ccfefd535c4033f40caa2342fa67d3a8c4c3f2 (diff)
downloadguix-patches-a790f262074c94f6b7acb118fb22981d71f1722f.tar
guix-patches-a790f262074c94f6b7acb118fb22981d71f1722f.tar.gz
gnu: nss: Increase test timeouts.
* gnu/packages/patches/nss-increase-test-timeout.patch: Wait up to 60s before regarding a test as failed.
Diffstat (limited to 'gnu/packages/patches/nss-increase-test-timeout.patch')
-rw-r--r--gnu/packages/patches/nss-increase-test-timeout.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/patches/nss-increase-test-timeout.patch b/gnu/packages/patches/nss-increase-test-timeout.patch
index 1e24940322..0895daff4e 100644
--- a/gnu/packages/patches/nss-increase-test-timeout.patch
+++ b/gnu/packages/patches/nss-increase-test-timeout.patch
@@ -1,4 +1,4 @@
-We've seen some tests take more than 20s to complete on a busy armhf
+We've seen some tests take up to a minute to complete on a busy armhf
machine. Even a busy x86_64 machine can use more than 5s on some tests.
Increase timeouts to increase chances of a successful build.
@@ -10,7 +10,7 @@ Increase timeouts to increase chances of a successful build.
ASSERT_TRUE_WAIT((client_->state() != TlsAgent::STATE_CONNECTING) &&
(server_->state() != TlsAgent::STATE_CONNECTING),
- 5000);
-+ 25000);
++ 60000);
}
void TlsConnectTestBase::EnableExtendedMasterSecret() {
@@ -19,7 +19,7 @@ Increase timeouts to increase chances of a successful build.
failing_agent = client_;
}
- ASSERT_TRUE_WAIT(failing_agent->state() == TlsAgent::STATE_ERROR, 5000);
-+ ASSERT_TRUE_WAIT(failing_agent->state() == TlsAgent::STATE_ERROR, 25000);
++ ASSERT_TRUE_WAIT(failing_agent->state() == TlsAgent::STATE_ERROR, 60000);
}
void TlsConnectTestBase::ConfigureVersion(uint16_t version) {