summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/nss-increase-test-timeout.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-06-12 19:27:02 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-06-12 21:31:12 +0200
commita10040e09b29eef72404c1f757fa7e20eb501dbb (patch)
tree6b076539122b1bc747879d41c76fb9203903384f /gnu/packages/patches/nss-increase-test-timeout.patch
parentc4395e782ea7c1392c91c3b491742127eb3de485 (diff)
downloadguix-patches-a10040e09b29eef72404c1f757fa7e20eb501dbb.tar
guix-patches-a10040e09b29eef72404c1f757fa7e20eb501dbb.tar.gz
gnu: nss, nss-certs: Update to 3.31.
Release notes: <https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS/NSS_3.31_release_notes> * gnu/packages/certs.scm (nss-certs): Update to 3.31. * gnu/packages/gnuzilla.scm (nss): Likewise. [source]<patches>: Remove upstream 'nss-disable-long-b64-tests' patch. [arguments]<#:phases>: Move armhf timeout substitution ... * gnu/packages/patches/nss-increase-test-timeout.patch: ... here. * gnu/packages/patches/nss-disable-long-b64-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/patches/nss-increase-test-timeout.patch')
-rw-r--r--gnu/packages/patches/nss-increase-test-timeout.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/patches/nss-increase-test-timeout.patch b/gnu/packages/patches/nss-increase-test-timeout.patch
index 1e24940322..55117c02e9 100644
--- a/gnu/packages/patches/nss-increase-test-timeout.patch
+++ b/gnu/packages/patches/nss-increase-test-timeout.patch
@@ -1,4 +1,4 @@
-We've seen some tests take more than 20s to complete on a busy armhf
+We've seen some tests take up to 60s to complete on a busy armhf
machine. Even a busy x86_64 machine can use more than 5s on some tests.
Increase timeouts to increase chances of a successful build.
@@ -10,7 +10,7 @@ Increase timeouts to increase chances of a successful build.
ASSERT_TRUE_WAIT((client_->state() != TlsAgent::STATE_CONNECTING) &&
(server_->state() != TlsAgent::STATE_CONNECTING),
- 5000);
-+ 25000);
++ 300000);
}
void TlsConnectTestBase::EnableExtendedMasterSecret() {
@@ -19,7 +19,7 @@ Increase timeouts to increase chances of a successful build.
failing_agent = client_;
}
- ASSERT_TRUE_WAIT(failing_agent->state() == TlsAgent::STATE_ERROR, 5000);
-+ ASSERT_TRUE_WAIT(failing_agent->state() == TlsAgent::STATE_ERROR, 25000);
++ ASSERT_TRUE_WAIT(failing_agent->state() == TlsAgent::STATE_ERROR, 300000);
}
void TlsConnectTestBase::ConfigureVersion(uint16_t version) {