summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/nss-increase-test-timeout.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-04-18 00:24:04 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-04-18 00:29:00 +0200
commit54fbac3fb56f7fc53afeaf83fed2cefdff793bde (patch)
treea18d2d211cdbb1ebd0d4ca43edd8b82e6d87a945 /gnu/packages/patches/nss-increase-test-timeout.patch
parente16c823f802d09965acf50cad64ab278dc01c1b2 (diff)
downloadguix-patches-54fbac3fb56f7fc53afeaf83fed2cefdff793bde.tar
guix-patches-54fbac3fb56f7fc53afeaf83fed2cefdff793bde.tar.gz
Revert "gnu: nss: Increase test timeouts."
This turned out to be a red herring: https://lists.gnu.org/archive/html/guix-devel/2017-04/msg00365.html This reverts commit a790f262074c94f6b7acb118fb22981d71f1722f.
Diffstat (limited to 'gnu/packages/patches/nss-increase-test-timeout.patch')
-rw-r--r--gnu/packages/patches/nss-increase-test-timeout.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/patches/nss-increase-test-timeout.patch b/gnu/packages/patches/nss-increase-test-timeout.patch
index 0895daff4e..1e24940322 100644
--- a/gnu/packages/patches/nss-increase-test-timeout.patch
+++ b/gnu/packages/patches/nss-increase-test-timeout.patch
@@ -1,4 +1,4 @@
-We've seen some tests take up to a minute to complete on a busy armhf
+We've seen some tests take more than 20s to complete on a busy armhf
machine. Even a busy x86_64 machine can use more than 5s on some tests.
Increase timeouts to increase chances of a successful build.
@@ -10,7 +10,7 @@ Increase timeouts to increase chances of a successful build.
ASSERT_TRUE_WAIT((client_->state() != TlsAgent::STATE_CONNECTING) &&
(server_->state() != TlsAgent::STATE_CONNECTING),
- 5000);
-+ 60000);
++ 25000);
}
void TlsConnectTestBase::EnableExtendedMasterSecret() {
@@ -19,7 +19,7 @@ Increase timeouts to increase chances of a successful build.
failing_agent = client_;
}
- ASSERT_TRUE_WAIT(failing_agent->state() == TlsAgent::STATE_ERROR, 5000);
-+ ASSERT_TRUE_WAIT(failing_agent->state() == TlsAgent::STATE_ERROR, 60000);
++ ASSERT_TRUE_WAIT(failing_agent->state() == TlsAgent::STATE_ERROR, 25000);
}
void TlsConnectTestBase::ConfigureVersion(uint16_t version) {