summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/netsurf-longer-test-timeout.patch
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2017-02-12 19:51:43 -0600
committerEric Bavier <bavier@member.fsf.org>2017-02-13 22:28:33 -0600
commit4fc282b32a16946d423cdbbdd7ee94d025d3b9f5 (patch)
tree095c6f98d8e5413a52088b12bf5bf11ca493ea32 /gnu/packages/patches/netsurf-longer-test-timeout.patch
parent710806b57b07500e1060fd32c1719b8ce8efbbe7 (diff)
downloadguix-patches-4fc282b32a16946d423cdbbdd7ee94d025d3b9f5.tar
guix-patches-4fc282b32a16946d423cdbbdd7ee94d025d3b9f5.tar.gz
gnu: netsurf: Enable tests.
* gnu/packages/patches/netsurf-longer-test-timeout.patch, gnu/packages/patches/netsurf-y2038-tests.patch: New patches. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/web.scm (netsurf)[source]: Use them. [native-inputs]: Add libidn, check. [inputs]: Add miscfiles. [arguments]: Remove #:tests?, add #:test-target. Add 'patch-check phase.
Diffstat (limited to 'gnu/packages/patches/netsurf-longer-test-timeout.patch')
-rw-r--r--gnu/packages/patches/netsurf-longer-test-timeout.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/patches/netsurf-longer-test-timeout.patch b/gnu/packages/patches/netsurf-longer-test-timeout.patch
new file mode 100644
index 0000000000..4dd5a8539f
--- /dev/null
+++ b/gnu/packages/patches/netsurf-longer-test-timeout.patch
@@ -0,0 +1,20 @@
+Increase the timeout on dictionary tests to accommodate slower machines.
+
+--- netsurf-3.6/test/hashtable.c
++++ netsurf-3.6/test/hashtable.c
+@@ -286,6 +286,7 @@
+ tcase_add_checked_fixture(tc_dict_s,
+ dicts_hashtable_create,
+ dict_hashtable_teardown);
++ tcase_set_timeout(tc_dict_s, 30);
+
+ tcase_add_test(tc_dict_s, hashtable_dict_test);
+
+@@ -297,6 +298,7 @@
+ tcase_add_checked_fixture(tc_dict_l,
+ dictl_hashtable_create,
+ dict_hashtable_teardown);
++ tcase_set_timeout(tc_dict_l, 30);
+
+ tcase_add_test(tc_dict_l, hashtable_dict_test);
+