summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/mupen64plus-ui-console-notice.patch
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-11-02 00:39:22 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-11-10 22:14:44 +0100
commite6974eae1d5d4111c789cf7cb347ba0658802c29 (patch)
treef3ddb4afdcb68e5d8f2d2e9038429bcd1d6e3a77 /gnu/packages/patches/mupen64plus-ui-console-notice.patch
parent17e2bc8617abcca0a6ade6fe598dc72ef70ca47a (diff)
downloadguix-patches-e6974eae1d5d4111c789cf7cb347ba0658802c29.tar
guix-patches-e6974eae1d5d4111c789cf7cb347ba0658802c29.tar.gz
gnu: Add mupen64plus-ui-console.
* gnu/packages/games.scm (mupen64plus-ui-console): New variable. * gnu/packages/patches/mupen64plus-ui-console-notice.patch: New file. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches/mupen64plus-ui-console-notice.patch')
-rw-r--r--gnu/packages/patches/mupen64plus-ui-console-notice.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/patches/mupen64plus-ui-console-notice.patch b/gnu/packages/patches/mupen64plus-ui-console-notice.patch
new file mode 100644
index 0000000000..1d0b4c46bb
--- /dev/null
+++ b/gnu/packages/patches/mupen64plus-ui-console-notice.patch
@@ -0,0 +1,34 @@
+Mupen64Plus supports a single data directory and a single plugin directory in
+its configuration, yet we need data and plugin files from a variety of
+packages. The best way to deal with this is to install all packages from
+which data and plugin files are needed into one's profile, and point the
+configuration there. Hence, the ui-console package provides propagated inputs
+for packages with the most important data and plugin files, and this patch
+provides the user instructions on what needs to be done in order to have
+Mupen64Plus find the relevant data and plugins.
+
+--- a/src/plugin.c
++++ b/src/plugin.c
+@@ -122,6 +122,22 @@ m64p_error PluginSearchLoad(m64p_handle ConfigUI)
+ {
+ const char *plugindir = (*ConfigGetParamString)(ConfigUI, "PluginDir");
+ lib_filelist = osal_library_search(plugindir);
++ /* Guix specific */
++ if (lib_filelist == NULL)
++ {
++ DebugMessage(M64MSG_ERROR, "No plugins found in PluginDir path: %s", plugindir);
++ DebugMessage(M64MSG_ERROR,
++ "\n\n"
++ "*********************************\n"
++ "*** Notice for GNU Guix users ***\n"
++ "*********************************\n"
++ "\n"
++ "You might want to edit your mupen64plus.cfg (in $XDG_CONFIG_HOME by default)\n"
++ "and set SharedDataPath to /path/to/my_guix_profile/share/mupen64plus and\n"
++ "PluginDir to /path/to/my_guix_profile/lib/mupen64plus so that data and plugins\n"
++ "are found.\n"
++ "\n");
++ }
+ }
+
+ /* if still no plugins found, search some common system folders */