summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/minisat-install.patch
diff options
context:
space:
mode:
authorRobert Smith <robertsmith@posteo.net>2019-11-16 16:18:43 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-11-19 17:27:58 +0100
commit3b7828cc7f938fcb369976cbe75d9c85f22583a1 (patch)
tree4814e0497cec93b82f6fa2c23d2d87cd20a63733 /gnu/packages/patches/minisat-install.patch
parent5dea5cbc62547f50a793ce905cdd4d1a62be60e1 (diff)
downloadguix-patches-3b7828cc7f938fcb369976cbe75d9c85f22583a1.tar
guix-patches-3b7828cc7f938fcb369976cbe75d9c85f22583a1.tar.gz
gnu: Add minisat.
* gnu/packages/patches/minisat-friend-declaration.patch: New file. * gnu/packages/patches/minisat-install.patch: New file. * gnu/local.mk (dist_patch_DATA): Add both files above. * gnu/packages/maths.scm (minisat): New exported variable. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
Diffstat (limited to 'gnu/packages/patches/minisat-install.patch')
-rw-r--r--gnu/packages/patches/minisat-install.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/patches/minisat-install.patch b/gnu/packages/patches/minisat-install.patch
new file mode 100644
index 0000000000..23cde89bec
--- /dev/null
+++ b/gnu/packages/patches/minisat-install.patch
@@ -0,0 +1,19 @@
+Avoid the default dynamic executable, which depends on minisat.so
+Instead install the release version, which is statically linked.
+
+diff --git a/Makefile b/Makefile
+index ceb9d77..7b91906 100644
+--- a/Makefile
++++ b/Makefile
+@@ -191,9 +191,9 @@ install-lib: $(BUILD_DIR)/release/lib/$(MINISAT_SLIB) $(BUILD_DIR)/dynamic/lib/$
+ ln -sf $(MINISAT_DLIB).$(SOMAJOR) $(DESTDIR)$(libdir)/$(MINISAT_DLIB)
+ $(INSTALL) -m 644 $(BUILD_DIR)/release/lib/$(MINISAT_SLIB) $(DESTDIR)$(libdir)
+
+-install-bin: $(BUILD_DIR)/dynamic/bin/$(MINISAT)
++install-bin: $(BUILD_DIR)/release/bin/$(MINISAT)
+ $(INSTALL) -d $(DESTDIR)$(bindir)
+- $(INSTALL) -m 755 $(BUILD_DIR)/dynamic/bin/$(MINISAT) $(DESTDIR)$(bindir)
++ $(INSTALL) -m 755 $(BUILD_DIR)/release/bin/$(MINISAT) $(DESTDIR)$(bindir)
+
+ clean:
+ rm -f $(foreach t, release debug profile dynamic, $(foreach o, $(SRCS:.cc=.o), $(BUILD_DIR)/$t/$o)) \