summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/meson-for-build-rpath.patch
diff options
context:
space:
mode:
authorPeter Mikkelsen <petermikkelsen10@gmail.com>2017-09-13 14:50:02 +0200
committerLudovic Courtès <ludo@gnu.org>2017-09-16 00:03:53 +0200
commitdab666cd8d91bf2c4aacc920e3ea2ec01221123f (patch)
treef52af9a4f0fbf38d2e7dbd2489c14ae514669d54 /gnu/packages/patches/meson-for-build-rpath.patch
parent67f8ba118e2b98755253a5b4ba647efb4314e03f (diff)
downloadguix-patches-dab666cd8d91bf2c4aacc920e3ea2ec01221123f.tar
guix-patches-dab666cd8d91bf2c4aacc920e3ea2ec01221123f.tar.gz
gnu: Add meson-for-build.
* gnu/packages/build-tools.scm (meson-for-build): New variable. * gnu/packages/patches/meson-for-build-rpath.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/meson-for-build-rpath.patch')
-rw-r--r--gnu/packages/patches/meson-for-build-rpath.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/patches/meson-for-build-rpath.patch b/gnu/packages/patches/meson-for-build-rpath.patch
new file mode 100644
index 0000000000..4e20c9aed3
--- /dev/null
+++ b/gnu/packages/patches/meson-for-build-rpath.patch
@@ -0,0 +1,24 @@
+This patch removes a part of meson that clears the rpath upon installation.
+This will only be applied to a special version of meson, used for the
+meson-build-system.
+
+Patch by Peter Mikkelsen <petermikkelsen10@gmail.com>
+
+--- meson-0.42.0/mesonbuild/scripts/meson_install.py.orig 2017-09-09 01:49:39.147374148 +0200
++++ meson-0.42.0/mesonbuild/scripts/meson_install.py 2017-09-09 01:51:01.209134717 +0200
+@@ -345,15 +345,6 @@
+ print("Symlink creation does not work on this platform. "
+ "Skipping all symlinking.")
+ printed_symlink_error = True
+- if is_elf_platform() and os.path.isfile(outname):
+- try:
+- e = depfixer.Elf(outname, False)
+- e.fix_rpath(install_rpath)
+- except SystemExit as e:
+- if isinstance(e.code, int) and e.code == 0:
+- pass
+- else:
+- raise
+
+ def run(args):
+ global install_log_file