summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/mesa-skip-disk-cache-test.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-04-17 20:48:43 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-04-17 21:26:41 +0200
commit0315b20a2c5d68d6b6d53ecd0f80964c5ca91d70 (patch)
tree220956f6470f521557f87910f2e764a8767f6889 /gnu/packages/patches/mesa-skip-disk-cache-test.patch
parent84080b4362c2e9abc932aa7bb6c916450d6080ce (diff)
downloadguix-patches-0315b20a2c5d68d6b6d53ecd0f80964c5ca91d70.tar
guix-patches-0315b20a2c5d68d6b6d53ecd0f80964c5ca91d70.tar.gz
gnu: mesa: Update to 17.0.4.
* gnu/packages/patches/mesa-skip-disk-cache-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gl.scm (mesa): Update to 17.0.4. [source]: Adapt URI to new directory structure. [arguments]: End phases on #t. Remove stray whitespaces. [home-page]: Use HTTPS.
Diffstat (limited to 'gnu/packages/patches/mesa-skip-disk-cache-test.patch')
-rw-r--r--gnu/packages/patches/mesa-skip-disk-cache-test.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/patches/mesa-skip-disk-cache-test.patch b/gnu/packages/patches/mesa-skip-disk-cache-test.patch
new file mode 100644
index 0000000000..4377110475
--- /dev/null
+++ b/gnu/packages/patches/mesa-skip-disk-cache-test.patch
@@ -0,0 +1,20 @@
+disk_cache_create() here looks up the users home directory from <pwd.h>
+which resolves to "/" in the build environment. I could not find an easy
+way to set the home directory to something else, so we disable this test
+for now.
+
+--- a/src/compiler/glsl/tests/cache_test.c
++++ b/src/compiler/glsl/tests/cache_test.c
+@@ -137,11 +137,6 @@
+ unsetenv("MESA_GLSL_CACHE_DIR");
+ unsetenv("XDG_CACHE_HOME");
+
+- cache = disk_cache_create();
+- expect_non_null(cache, "disk_cache_create with no environment variables");
+-
+- disk_cache_destroy(cache);
+-
+ /* Test with XDG_CACHE_HOME set */
+ setenv("XDG_CACHE_HOME", CACHE_TEST_TMP "/xdg-cache-home", 1);
+ cache = disk_cache_create();
+