summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/mcrypt-CVE-2012-4527.patch
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-05-30 21:45:00 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-05-30 21:57:36 +0300
commitfd1461879c63c608617d30524183a71370a7451c (patch)
tree4d22c85513c259ed165ee32eee38ad6b7db3aa4b /gnu/packages/patches/mcrypt-CVE-2012-4527.patch
parent5ae77a6f5a3b6d38c2279f97e31f0f35adc7c29b (diff)
downloadguix-patches-fd1461879c63c608617d30524183a71370a7451c.tar
guix-patches-fd1461879c63c608617d30524183a71370a7451c.tar.gz
gnu: mcrypt: Fix CVE-2012-4409, CVE-2012-4426, CVE-2012-4527.
* gnu/packages/mcrypt.scm (mcrypt)[source]: Add patches. * gnu/packages/patches/mcrypt-CVE-2012-4409.patch, gnu/packages/patches/mcrypt-CVE-2012-4426.patch, gnu/packages/patches/mcrypt-CVE-2012-4527.patch: New variables. * gnu/local.mk (dist_patch_DATA): Add them.
Diffstat (limited to 'gnu/packages/patches/mcrypt-CVE-2012-4527.patch')
-rw-r--r--gnu/packages/patches/mcrypt-CVE-2012-4527.patch111
1 files changed, 111 insertions, 0 deletions
diff --git a/gnu/packages/patches/mcrypt-CVE-2012-4527.patch b/gnu/packages/patches/mcrypt-CVE-2012-4527.patch
new file mode 100644
index 0000000000..d931dd174b
--- /dev/null
+++ b/gnu/packages/patches/mcrypt-CVE-2012-4527.patch
@@ -0,0 +1,111 @@
+From b0716eac4e800a0ea53e1b949250f671702f28a0 Mon Sep 17 00:00:00 2001
+From: Tom Callaway <spot@fedoraproject.org>
+Date: Tue, 30 Oct 2012 15:39:24 -0400
+Subject: apply workaround to CVE-2012-4527
+
+---
+ mcrypt-CVE-2012-4527-80-width-patch | 91 +++++++++++++++++++++++++++++++++++++
+ mcrypt.spec | 10 +++-
+ 2 files changed, 100 insertions(+), 1 deletion(-)
+ create mode 100644 mcrypt-CVE-2012-4527-80-width-patch
+
+diff --git a/mcrypt-CVE-2012-4527-80-width-patch b/mcrypt-CVE-2012-4527-80-width-patch
+new file mode 100644
+index 0000000..0eb94d8
+--- /dev/null
++++ b/mcrypt-CVE-2012-4527-80-width-patch
+@@ -0,0 +1,91 @@
++--- mcrypt-2.6.8.orig/src/mcrypt.c
+++++ mcrypt-2.6.8/src/mcrypt.c
++@@ -41,6 +41,8 @@
++ # include <time.h>
++ #endif
++
+++#define WIDTH 80
+++
++ static char rcsid[] =
++ "$Id: mcrypt.c,v 1.2 2007/11/07 17:10:21 nmav Exp $";
++
++@@ -482,7 +484,7 @@
++ #ifdef HAVE_STAT
++ if (stream_flag == FALSE) {
++ if (is_normal_file(file[i]) == FALSE) {
++- sprintf(tmperr,
+++ snprintf(tmperr, WIDTH,
++ _
++ ("%s: %s is not a regular file. Skipping...\n"),
++ program_name, file[i]);
++@@ -501,7 +503,7 @@
++ dinfile = file[i];
++ if ((isatty(fileno((FILE *) (stdin))) == 1)
++ && (stream_flag == TRUE) && (force == 0)) { /* not a tty */
++- sprintf(tmperr,
+++ snprintf(tmperr, WIDTH,
++ _
++ ("%s: Encrypted data will not be read from a terminal.\n"),
++ program_name);
++@@ -520,7 +522,7 @@
++ einfile = file[i];
++ if ((isatty(fileno((FILE *) (stdout))) == 1)
++ && (stream_flag == TRUE) && (force == 0)) { /* not a tty */
++- sprintf(tmperr,
+++ snprintf(tmperr, WIDTH,
++ _
++ ("%s: Encrypted data will not be written to a terminal.\n"),
++ program_name);
++@@ -544,7 +546,7 @@
++ strcpy(outfile, einfile);
++ /* if file has already the .nc ignore it */
++ if (strstr(outfile, ".nc") != NULL) {
++- sprintf(tmperr,
+++ snprintf(tmperr, WIDTH,
++ _
++ ("%s: file %s has the .nc suffix... skipping...\n"),
++ program_name, outfile);
++@@ -590,10 +592,10 @@
++
++ if (x == 0) {
++ if (stream_flag == FALSE) {
++- sprintf(tmperr, _("File %s was decrypted.\n"), dinfile);
+++ snprintf(tmperr, WIDTH, _("File %s was decrypted.\n"), dinfile);
++ err_warn(tmperr);
++ } else {
++- sprintf(tmperr, _("Stdin was decrypted.\n"));
+++ snprintf(tmperr, WIDTH, _("Stdin was decrypted.\n"));
++ err_warn(tmperr);
++ }
++ #ifdef HAVE_STAT
++@@ -610,7 +612,7 @@
++
++ } else {
++ if (stream_flag == FALSE) {
++- sprintf(tmperr,
+++ snprintf(tmperr, WIDTH,
++ _
++ ("File %s was NOT decrypted successfully.\n"),
++ dinfile);
++@@ -636,10 +638,10 @@
++
++ if (x == 0) {
++ if (stream_flag == FALSE) {
++- sprintf(tmperr, _("File %s was encrypted.\n"), einfile);
+++ snprintf(tmperr, WIDTH, _("File %s was encrypted.\n"), einfile);
++ err_warn(tmperr);
++ } else {
++- sprintf(tmperr, _("Stdin was encrypted.\n"));
+++ snprintf(tmperr, WIDTH, _("Stdin was encrypted.\n"));
++ err_warn(tmperr);
++ }
++ #ifdef HAVE_STAT
++@@ -655,7 +657,7 @@
++
++ } else {
++ if (stream_flag == FALSE) {
++- sprintf(tmperr,
+++ snprintf(tmperr, WIDTH,
++ _
++ ("File %s was NOT encrypted successfully.\n"),
++ einfile);
+--
+cgit v0.12
+