summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/mcrypt-CVE-2012-4426.patch
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-05-30 21:45:00 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-05-30 21:57:36 +0300
commitfd1461879c63c608617d30524183a71370a7451c (patch)
tree4d22c85513c259ed165ee32eee38ad6b7db3aa4b /gnu/packages/patches/mcrypt-CVE-2012-4426.patch
parent5ae77a6f5a3b6d38c2279f97e31f0f35adc7c29b (diff)
downloadguix-patches-fd1461879c63c608617d30524183a71370a7451c.tar
guix-patches-fd1461879c63c608617d30524183a71370a7451c.tar.gz
gnu: mcrypt: Fix CVE-2012-4409, CVE-2012-4426, CVE-2012-4527.
* gnu/packages/mcrypt.scm (mcrypt)[source]: Add patches. * gnu/packages/patches/mcrypt-CVE-2012-4409.patch, gnu/packages/patches/mcrypt-CVE-2012-4426.patch, gnu/packages/patches/mcrypt-CVE-2012-4527.patch: New variables. * gnu/local.mk (dist_patch_DATA): Add them.
Diffstat (limited to 'gnu/packages/patches/mcrypt-CVE-2012-4426.patch')
-rw-r--r--gnu/packages/patches/mcrypt-CVE-2012-4426.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/patches/mcrypt-CVE-2012-4426.patch b/gnu/packages/patches/mcrypt-CVE-2012-4426.patch
new file mode 100644
index 0000000000..61c197b0c9
--- /dev/null
+++ b/gnu/packages/patches/mcrypt-CVE-2012-4426.patch
@@ -0,0 +1,36 @@
+diff --git a/mcrypt-CVE-2012-4426.patch b/mcrypt-CVE-2012-4426.patch
+new file mode 100644
+index 0000000..747f428
+--- mcrypt-2.6.8/src/errors.c
++++ mcrypt-2.6.8/src/errors.c
+@@ -25,24 +25,24 @@
+
+ void err_quit(char *errmsg)
+ {
+- fprintf(stderr, errmsg);
++ fprintf(stderr, "%s", errmsg);
+ exit(-1);
+ }
+
+ void err_warn(char *errmsg)
+ {
+ if (quiet <= 1)
+- fprintf(stderr, errmsg);
++ fprintf(stderr, "%s", errmsg);
+ }
+
+ void err_info(char *errmsg)
+ {
+ if (quiet == 0)
+- fprintf(stderr, errmsg);
++ fprintf(stderr, "%s", errmsg);
+ }
+
+ void err_crit(char *errmsg)
+ {
+ if (quiet <= 2)
+- fprintf(stderr, errmsg);
++ fprintf(stderr, "%s", errmsg);
+ }
+
+---