summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/mcrypt-CVE-2012-4409.patch
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-04 02:37:51 -0500
committerLeo Famulari <leo@famulari.name>2017-01-04 02:46:51 -0500
commit324f4fc559b4cf9f7df0bc334ac8a0a4fa040c22 (patch)
treef1e52d1256d164c007e148bd1490a067197f9118 /gnu/packages/patches/mcrypt-CVE-2012-4409.patch
parent37e8a2e219b21a43f80e9cf8581db1b1e2f67105 (diff)
downloadguix-patches-324f4fc559b4cf9f7df0bc334ac8a0a4fa040c22.tar
guix-patches-324f4fc559b4cf9f7df0bc334ac8a0a4fa040c22.tar.gz
gnu: mcrypt: Fix patches for CVE-2012-{4409,4527}.
This fixes CVE-2012-{4409,4527}. This is a followup to commit fd1461879c63c608617d30524183a71370a7451c. * gnu/packages/patches/mcrypt-CVE-2012-4409.patch, gnu/packages/patches/mcrypt-CVE-2012-4527.patch: Apply the patches to the mcrypt source code.
Diffstat (limited to 'gnu/packages/patches/mcrypt-CVE-2012-4409.patch')
-rw-r--r--gnu/packages/patches/mcrypt-CVE-2012-4409.patch35
1 files changed, 11 insertions, 24 deletions
diff --git a/gnu/packages/patches/mcrypt-CVE-2012-4409.patch b/gnu/packages/patches/mcrypt-CVE-2012-4409.patch
index 60cf8e0430..3089f962f7 100644
--- a/gnu/packages/patches/mcrypt-CVE-2012-4409.patch
+++ b/gnu/packages/patches/mcrypt-CVE-2012-4409.patch
@@ -3,30 +3,17 @@ From: Tom Callaway <spot@fedoraproject.org>
Date: Fri, 7 Sep 2012 11:39:29 -0400
Subject: apply fix for CVE-2012-4409 (thanks to Raphael Geissert)
----
- mcrypt-CVE-2012-4409.patch | 12 ++++++++++++
- mcrypt.spec | 10 +++++++++-
- 2 files changed, 21 insertions(+), 1 deletion(-)
- create mode 100644 mcrypt-CVE-2012-4409.patch
-
-diff --git a/mcrypt-CVE-2012-4409.patch b/mcrypt-CVE-2012-4409.patch
-new file mode 100644
-index 0000000..747f428
---- /dev/null
-+++ b/mcrypt-CVE-2012-4409.patch
-@@ -0,0 +1,12 @@
-+diff -up mcrypt-2.6.8/src/extra.c.CVE-2012-4409 mcrypt-2.6.8/src/extra.c
-+--- mcrypt-2.6.8/src/extra.c.CVE-2012-4409 2012-09-07 11:00:55.906870746 -0400
-++++ mcrypt-2.6.8/src/extra.c 2012-09-07 11:00:27.967858365 -0400
-+@@ -242,6 +242,8 @@ int check_file_head(FILE * fstream, char
-+ if (m_getbit(0, sflag) != 0) { /* if the first bit is set */
-+ *salt_size = m_setbit(0, sflag, 0);
-+ if (*salt_size > 0) {
-++ if (*salt_size > sizeof(tmp_buf))
-++ err_quit(_("Salt is too long\n"));
-+ fread(tmp_buf, 1, *salt_size,
-+ fstream);
-+ memmove(salt, tmp_buf, *salt_size);
+--- mcrypt-2.6.8/src/extra.c.CVE-2012-4409 2012-09-07 11:00:55.906870746 -0400
++++ mcrypt-2.6.8/src/extra.c 2012-09-07 11:00:27.967858365 -0400
+@@ -242,6 +242,8 @@ int check_file_head(FILE * fstream, char
+ if (m_getbit(0, sflag) != 0) { /* if the first bit is set */
+ *salt_size = m_setbit(0, sflag, 0);
+ if (*salt_size > 0) {
++ if (*salt_size > sizeof(tmp_buf))
++ err_quit(_("Salt is too long\n"));
+ fread(tmp_buf, 1, *salt_size,
+ fstream);
+ memmove(salt, tmp_buf, *salt_size);
--
cgit v0.12