summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/lua-CVE-2014-5461.patch
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-05-29 08:50:15 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-05-29 09:47:46 +0300
commit32fddd8e29ba6bfebc7ba2081f02d2dc9730256a (patch)
tree69bbec1ebbfda9e34e4487d077ba988ef9727850 /gnu/packages/patches/lua-CVE-2014-5461.patch
parent576b1aeed6c315370135025d3cd4db54c388a143 (diff)
downloadguix-patches-32fddd8e29ba6bfebc7ba2081f02d2dc9730256a.tar
guix-patches-32fddd8e29ba6bfebc7ba2081f02d2dc9730256a.tar.gz
gnu: lua-5.1: Fix CVE-2014-5461.
* gnu/packages/lua.scm (lua-5.1)[source]: Add patch. * gnu/packages/patches/lua-CVE-2014-5461: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches/lua-CVE-2014-5461.patch')
-rw-r--r--gnu/packages/patches/lua-CVE-2014-5461.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/patches/lua-CVE-2014-5461.patch b/gnu/packages/patches/lua-CVE-2014-5461.patch
new file mode 100644
index 0000000000..bc72ef14ad
--- /dev/null
+++ b/gnu/packages/patches/lua-CVE-2014-5461.patch
@@ -0,0 +1,20 @@
+From: Enrico Tassi <gareuselesinge@debian.org>
+Date: Tue, 26 Aug 2014 16:20:55 +0200
+Subject: Fix stack overflow in vararg functions
+
+---
+ src/ldo.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/ldo.c b/src/ldo.c
+index d1bf786..30333bf 100644
+--- a/src/ldo.c
++++ b/src/ldo.c
+@@ -274,7 +274,7 @@ int luaD_precall (lua_State *L, StkId func, int nresults) {
+ CallInfo *ci;
+ StkId st, base;
+ Proto *p = cl->p;
+- luaD_checkstack(L, p->maxstacksize);
++ luaD_checkstack(L, p->maxstacksize + p->numparams);
+ func = restorestack(L, funcr);
+ base = func + 1;