summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/llvm-3.x.1-fix-build-with-gcc.patch
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-07-08 15:58:49 +0000
committerLudovic Courtès <ludo@gnu.org>2022-07-12 01:17:45 +0200
commit3485984a090edd5b1721a69a389a2e44077354e7 (patch)
tree73bd1c1545d574b6926cfef9d6b0562f00c2d980 /gnu/packages/patches/llvm-3.x.1-fix-build-with-gcc.patch
parente5e352ae2a92d6653dbb906eeeeb63c072b7184c (diff)
downloadguix-patches-3485984a090edd5b1721a69a389a2e44077354e7.tar
guix-patches-3485984a090edd5b1721a69a389a2e44077354e7.tar.gz
gnu: llvm-3.7, llvm-3.8: Fix build with gcc.
* gnu/packages/patches/clang-runtime-3.7-fix-build-with-python3.patch, gnu/packages/patches/llvm-3.x.1-fix-build-with-gcc.patch: New files. * gnu/packages/llvm.scm (clang-runtime-3.7, llvm-3.7, llvm-3.8): Use patches. * gnu/local.mk: Register patches. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/llvm-3.x.1-fix-build-with-gcc.patch')
-rw-r--r--gnu/packages/patches/llvm-3.x.1-fix-build-with-gcc.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/llvm-3.x.1-fix-build-with-gcc.patch b/gnu/packages/patches/llvm-3.x.1-fix-build-with-gcc.patch
new file mode 100644
index 0000000000..75236c4069
--- /dev/null
+++ b/gnu/packages/patches/llvm-3.x.1-fix-build-with-gcc.patch
@@ -0,0 +1,15 @@
+Patch from https://github.com/digego/extempore/issues/318
+
+diff --git a/include/llvm/IR/ValueMap.h.orig b/include/llvm/IR/ValueMap.h
+index ad518ac..d928f6a 100644
+--- a/include/llvm/IR/ValueMap.h
++++ b/include/llvm/IR/ValueMap.h
+@@ -99,7 +99,7 @@
+ explicit ValueMap(const ExtraData &Data, unsigned NumInitBuckets = 64)
+ : Map(NumInitBuckets), Data(Data) {}
+
+- bool hasMD() const { return MDMap; }
++ bool hasMD() const { return static_cast<bool>(MDMap); }
+ MDMapT &MD() {
+ if (!MDMap)
+ MDMap.reset(new MDMapT);