summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/llvm-3.6-fix-build-with-gcc-10.patch
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-10-07 14:21:25 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-10-07 14:21:25 +0200
commit99d288a6b1efba1ce53f07b01644bd8932979d4f (patch)
treef03b07bbee1cb28ab65c0ba6095f71021d4e90d8 /gnu/packages/patches/llvm-3.6-fix-build-with-gcc-10.patch
parent1ac5bd7c0bbe9a908a440b5233ee2620b9ec77d7 (diff)
downloadguix-patches-99d288a6b1efba1ce53f07b01644bd8932979d4f.tar
guix-patches-99d288a6b1efba1ce53f07b01644bd8932979d4f.tar.gz
gnu: llvm-3.6: Fix build.
* gnu/packages/patches/llvm-3.6-fix-build-with-gcc-10.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/llvm.scm (llvm-3.6)[source]: Use it.
Diffstat (limited to 'gnu/packages/patches/llvm-3.6-fix-build-with-gcc-10.patch')
-rw-r--r--gnu/packages/patches/llvm-3.6-fix-build-with-gcc-10.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/llvm-3.6-fix-build-with-gcc-10.patch b/gnu/packages/patches/llvm-3.6-fix-build-with-gcc-10.patch
new file mode 100644
index 0000000000..4982587d15
--- /dev/null
+++ b/gnu/packages/patches/llvm-3.6-fix-build-with-gcc-10.patch
@@ -0,0 +1,13 @@
+Adapted from https://github.com/digego/extempore/pull/322/files
+
+--- a/include/llvm/IR/ValueMap.h 2015-08-04 00:30:24.000000000 +0200
++++ b/include/llvm/IR/ValueMap.h 2018-07-14 21:09:09.769502736 +0200
+@@ -99,7 +99,7 @@
+ explicit ValueMap(const ExtraData &Data, unsigned NumInitBuckets = 64)
+ : Map(NumInitBuckets), Data(Data) {}
+
+- bool hasMD() const { return MDMap; }
++ bool hasMD() const { return static_cast<bool>(MDMap); }
+ MDMapT &MD() {
+ if (!MDMap)
+ MDMap.reset(new MDMapT);