summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libvpx-CVE-2016-2818.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-02-09 14:58:54 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-09 14:58:54 +0100
commit65064909ed2c30f45048f85cf02771316d6c6cfc (patch)
treea6138b1cea5bbafc9d12d8759e1061e7be9d18a7 /gnu/packages/patches/libvpx-CVE-2016-2818.patch
parent206af46fe1cc0627e4846167aa5e7c095b21afe3 (diff)
downloadguix-patches-65064909ed2c30f45048f85cf02771316d6c6cfc.tar
guix-patches-65064909ed2c30f45048f85cf02771316d6c6cfc.tar.gz
gnu: libvpx: Update to 1.6.1.
* gnu/packages/video.scm (libvpx): Update to 1.6.1. * gnu/packages/patches/libvpx-CVE-2016-2818.patch: Adjust to indentation changes.
Diffstat (limited to 'gnu/packages/patches/libvpx-CVE-2016-2818.patch')
-rw-r--r--gnu/packages/patches/libvpx-CVE-2016-2818.patch21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/patches/libvpx-CVE-2016-2818.patch b/gnu/packages/patches/libvpx-CVE-2016-2818.patch
index 1fdf01cbca..bef3448b81 100644
--- a/gnu/packages/patches/libvpx-CVE-2016-2818.patch
+++ b/gnu/packages/patches/libvpx-CVE-2016-2818.patch
@@ -9,15 +9,15 @@ Patch contents copied from Mozilla esr45 changeset 312077:7ebfe49f001c
--- libvpx-1.5.0/vp8/vp8_cx_iface.c.orig 2015-11-09 17:12:38.000000000 -0500
+++ libvpx-1.5.0/vp8/vp8_cx_iface.c 2016-06-08 08:48:46.037213092 -0400
-@@ -925,11 +925,19 @@
- {
- res = image2yuvconfig(img, &sd);
+@@ -860,11 +860,20 @@
+ if (img != NULL) {
+ res = image2yuvconfig(img, &sd);
-- if (vp8_receive_raw_frame(ctx->cpi, ctx->next_frame_flag | lib_flags,
-- &sd, dst_time_stamp, dst_end_time_stamp))
-- {
-- VP8_COMP *cpi = (VP8_COMP *)ctx->cpi;
-- res = update_error_state(ctx, &cpi->common.error);
+- if (vp8_receive_raw_frame(ctx->cpi, ctx->next_frame_flag | lib_flags, &sd,
+- dst_time_stamp, dst_end_time_stamp)) {
+- VP8_COMP *cpi = (VP8_COMP *)ctx->cpi;
+- res = update_error_state(ctx, &cpi->common.error);
+- }
+ if (sd.y_width != ctx->cfg.g_w || sd.y_height != ctx->cfg.g_h) {
+ /* from vp8_encoder.h for g_w/g_h:
+ "Note that the frames passed as input to the encoder must have this resolution"
@@ -31,6 +31,7 @@ Patch contents copied from Mozilla esr45 changeset 312077:7ebfe49f001c
+ VP8_COMP *cpi = (VP8_COMP *)ctx->cpi;
+ res = update_error_state(ctx, &cpi->common.error);
+ }
- }
++ }
- /* reset for next frame */
+ /* reset for next frame */
+ ctx->next_frame_flag = 0;