summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libusb-for-axoloti.patch
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-03-03 18:08:32 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-10-17 16:49:20 +0200
commitd991b0566433b0ff78dd92165430da2f40fe721d (patch)
tree015f4d7e1c507904eac15382b497a006356b91dc /gnu/packages/patches/libusb-for-axoloti.patch
parent8843373322b2d1a95175c578659fb1521461ef6a (diff)
downloadguix-patches-d991b0566433b0ff78dd92165430da2f40fe721d.tar
guix-patches-d991b0566433b0ff78dd92165430da2f40fe721d.tar.gz
gnu: Add Axoloti.
* gnu/packages/axoloti.scm: New file. * gnu/packages/patches/libusb-for-axoloti.patch: New file. * gnu/local.mk (dist_patch_DATA): Add patch. (GNU_SYSTEM_MODULES): Add module.
Diffstat (limited to 'gnu/packages/patches/libusb-for-axoloti.patch')
-rw-r--r--gnu/packages/patches/libusb-for-axoloti.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/libusb-for-axoloti.patch b/gnu/packages/patches/libusb-for-axoloti.patch
new file mode 100644
index 0000000000..2c07d767d9
--- /dev/null
+++ b/gnu/packages/patches/libusb-for-axoloti.patch
@@ -0,0 +1,14 @@
+diff -rp -u4 libusb-1.0.19-orig/libusb/descriptor.c libusb-1.0.19/libusb/descriptor.c
+--- libusb-1.0.19-orig/libusb/descriptor.c 2015-05-12 00:15:19 +0200
++++ libusb-1.0.19/libusb/descriptor.c 2015-05-12 00:17:09 +0200
+@@ -1181,9 +1181,9 @@ int API_EXPORTED libusb_get_string_descr
+ if (tbuf[1] != LIBUSB_DT_STRING)
+ return LIBUSB_ERROR_IO;
+
+ if (tbuf[0] > r)
+- return LIBUSB_ERROR_IO;
++ tbuf[0] = r;
+
+ for (di = 0, si = 2; si < tbuf[0]; si += 2) {
+ if (di >= (length - 1))
+ break;