summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libotr-test-auth-fix.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-03-17 19:03:15 -0400
committerMark H Weaver <mhw@netris.org>2016-03-17 19:05:08 -0400
commite3d3546edab80d9d14b6caa4e4f05e57938c645b (patch)
tree56d47f89a6e2a6a65e39d58bb6f889316e93cf3e /gnu/packages/patches/libotr-test-auth-fix.patch
parentb879b3e848d9cf4f4cc39ba8164f8b6be346313c (diff)
downloadguix-patches-e3d3546edab80d9d14b6caa4e4f05e57938c645b.tar
guix-patches-e3d3546edab80d9d14b6caa4e4f05e57938c645b.tar.gz
gnu: libotr: Fix tests on mips64el.
* gnu/packages/patches/libotr-test-auth-fix.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/messaging.scm (libotr)[source]: Add patch.
Diffstat (limited to 'gnu/packages/patches/libotr-test-auth-fix.patch')
-rw-r--r--gnu/packages/patches/libotr-test-auth-fix.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/libotr-test-auth-fix.patch b/gnu/packages/patches/libotr-test-auth-fix.patch
new file mode 100644
index 0000000000..23b8d8308d
--- /dev/null
+++ b/gnu/packages/patches/libotr-test-auth-fix.patch
@@ -0,0 +1,15 @@
+Initialize the context in 'test_auth_clear'.
+Fixes the test suite on mips64el.
+
+Patch by Mark H Weaver <mhw@netris.org>
+
+--- libotr-4.1.1/tests/unit/test_auth.c.orig 2015-12-25 12:39:45.000000000 -0500
++++ libotr-4.1.1/tests/unit/test_auth.c 2016-03-17 18:53:10.169999706 -0400
+@@ -67,6 +67,7 @@
+ OtrlAuthInfo *auth = &ctx.auth;
+
+ /* API call. */
++ otrl_auth_new(&ctx);
+ otrl_auth_clear(auth);
+
+ ok(auth->authstate == OTRL_AUTHSTATE_NONE &&