summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libjxr-fix-typos.patch
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2016-11-03 13:36:02 -0400
committerKei Kebreau <kei@openmailbox.org>2016-11-03 13:43:23 -0400
commitb81245ccb38dc16d115519dd3166d8bb2c295bb8 (patch)
tree760fa31575c6c4a515c785bdfc765bc0b93734a7 /gnu/packages/patches/libjxr-fix-typos.patch
parente3100110ce9c1861f64a638ffd91fd34e15db77c (diff)
downloadguix-patches-b81245ccb38dc16d115519dd3166d8bb2c295bb8.tar
guix-patches-b81245ccb38dc16d115519dd3166d8bb2c295bb8.tar.gz
[PATCH] gnu: Add libjxr.
* gnu/packages/image.scm (libjxr): New variable. * gnu/packages/patches/libjxr-fix-function-signature.patch: New file. * gnu/packages/patches/libjxr-fix-typos.patch: New file. * gnu/local.mk (dist_patch_DATA): Register patches.
Diffstat (limited to 'gnu/packages/patches/libjxr-fix-typos.patch')
-rw-r--r--gnu/packages/patches/libjxr-fix-typos.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/patches/libjxr-fix-typos.patch b/gnu/packages/patches/libjxr-fix-typos.patch
new file mode 100644
index 0000000000..819db34900
--- /dev/null
+++ b/gnu/packages/patches/libjxr-fix-typos.patch
@@ -0,0 +1,29 @@
+Description: Fix typos and remove some warnings
+Author: Mathieu Malaterre <malat@debian.org>
+
+Index: jxrlib-1.1/jxrencoderdecoder/JxrEncApp.c
+===================================================================
+--- jxrlib-1.1.orig/jxrencoderdecoder/JxrEncApp.c
++++ jxrlib-1.1/jxrencoderdecoder/JxrEncApp.c
+@@ -578,7 +578,7 @@ main(int argc, char* argv[])
+
+ //================================
+ Call(PKCreateCodecFactory(&pCodecFactory, WMP_SDK_VERSION));
+- Call(pCodecFactory->CreateCodec(&IID_PKImageWmpEncode, &pEncoder));
++ Call(pCodecFactory->CreateCodec(&IID_PKImageWmpEncode, (void**)&pEncoder));
+
+ //----------------------------------------------------------------
+ Call(PKCreateTestFactory(&pTestFactory, WMP_SDK_VERSION));
+Index: jxrlib-1.1/jxrgluelib/JXRMeta.h
+===================================================================
+--- jxrlib-1.1.orig/jxrgluelib/JXRMeta.h
++++ jxrlib-1.1/jxrgluelib/JXRMeta.h
+@@ -34,7 +34,7 @@
+
+ #ifndef UNREFERENCED_PARAMETER
+ #define UNREFERENCED_PARAMETER(P) { (P) = (P); }
+-#endif UNREFERENCED_PARAMETER
++#endif /*UNREFERENCED_PARAMETER*/
+
+ //================================================================
+ // Container