summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libgnome-encoding.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-01-13 00:09:23 +0100
committerLudovic Courtès <ludo@gnu.org>2018-01-13 00:09:23 +0100
commit17c3eea760ae4190b48b191d67c73a50f7691bdd (patch)
tree6278d94aac29e615d0f0e22fc83d59f1004bdd5b /gnu/packages/patches/libgnome-encoding.patch
parentad514303982d218da5488ecbe834ae311405afb3 (diff)
downloadguix-patches-17c3eea760ae4190b48b191d67c73a50f7691bdd.tar
guix-patches-17c3eea760ae4190b48b191d67c73a50f7691bdd.tar.gz
gnu: libgnome: Adjust for latest GLib.
* gnu/packages/patches/libgnome-encoding.patch: New file. * gnu/packages/gnome.scm (libgnome)[source]: Use it. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches/libgnome-encoding.patch')
-rw-r--r--gnu/packages/patches/libgnome-encoding.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/libgnome-encoding.patch b/gnu/packages/patches/libgnome-encoding.patch
new file mode 100644
index 0000000000..c7c352172f
--- /dev/null
+++ b/gnu/packages/patches/libgnome-encoding.patch
@@ -0,0 +1,16 @@
+Remove non-UTF-8 character (this is a NO-BREAK SPACE character, encoded in
+ISO-8859-1) to fix build failure with 'glib-mkenums' in GLib 2.54.2+.
+
+Patch from <https://github.com/macports/macports-ports/commit/1f3efc8e65cc060d1701407bd1e56e62e6bd9c55>.
+
+--- a/libgnome/gnome-config.h 2009-04-23 04:29:13.000000000 -0500
++++ b/libgnome/gnome-config.h 2017-10-04 02:17:22.000000000 -0500
+@@ -270,7 +270,7 @@ void gnome_config_clean_key_ (const char
+ #define gnome_config_private_clean_key(path) \
+ (gnome_config_clean_key_((path),TRUE))
+
+-/* returns the true filename of the config file */
++/* returns the true filename of the config file */
+ #define gnome_config_get_real_path(path) \
+ (g_build_filename (gnome_user_dir_get(),(path),NULL))
+ #define gnome_config_private_get_real_path(path) \