summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/kpmcore-remove-broken-test.patch
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-10 21:44:54 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-10 22:18:20 +0100
commit38988dbecf9e1ee83258c5625bb8fdacff82ed3d (patch)
treec1f68f195017bb2286b11d9739b40b7fbad430ca /gnu/packages/patches/kpmcore-remove-broken-test.patch
parent15cd7067537b9fdae21e7ca7b9e25da4a6476c14 (diff)
downloadguix-patches-38988dbecf9e1ee83258c5625bb8fdacff82ed3d.tar
guix-patches-38988dbecf9e1ee83258c5625bb8fdacff82ed3d.tar.gz
gnu: kpmcore: Update to 4.0.1.
* gnu/packages/kde.scm(kpmcore): Update to 4.0.1. [origin]: Add upstream patches for making tests pass. [inputs]: Add qttools. Remove kiconthemes, kservice, libatasmart, parted. [arguments]: New element. * gnu/packages/patches/kpmcore-fix-tests.patch, gnu/packages/patches/kpmcore-remove-broken-test.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. add patches
Diffstat (limited to 'gnu/packages/patches/kpmcore-remove-broken-test.patch')
-rw-r--r--gnu/packages/patches/kpmcore-remove-broken-test.patch139
1 files changed, 139 insertions, 0 deletions
diff --git a/gnu/packages/patches/kpmcore-remove-broken-test.patch b/gnu/packages/patches/kpmcore-remove-broken-test.patch
new file mode 100644
index 0000000000..d02cca7883
--- /dev/null
+++ b/gnu/packages/patches/kpmcore-remove-broken-test.patch
@@ -0,0 +1,139 @@
+From c9a08a593bac8b8610a647db118fea6f2958156d Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andrius=20=C5=A0tikonas?= <andrius@stikonas.eu>
+Date: Thu, 7 Nov 2019 22:12:00 +0000
+Subject: [PATCH] Remove broken smart unit test.
+
+BUG: 413853
+---
+ test/CMakeLists.txt | 9 ----
+ test/testsmart.cpp | 102 --------------------------------------------
+ 2 files changed, 111 deletions(-)
+ delete mode 100644 test/testsmart.cpp
+
+diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
+index 67f63a2..6a300d3 100644
+--- a/test/CMakeLists.txt
++++ b/test/CMakeLists.txt
+@@ -53,12 +53,3 @@ find_package (Threads)
+ # Execute external commands as root
+ kpm_test(testexternalcommand testexternalcommand.cpp)
+ add_test(NAME testexternalcommand COMMAND testexternalcommand ${BACKEND})
+-
+-# Including SMART files reference
+-set(SMARTPARSER ${CMAKE_SOURCE_DIR}/src/core/smartdiskinformation.cpp
+- ${CMAKE_SOURCE_DIR}/src/core/smartattributeparseddata.cpp
+- ${CMAKE_SOURCE_DIR}/src/core/smartparser.cpp)
+-
+-# Test SMART support
+-kpm_test(testsmart testsmart.cpp ${SMARTPARSER})
+-add_test(NAME testsmart COMMAND testsmart ${BACKEND})
+diff --git a/test/testsmart.cpp b/test/testsmart.cpp
+deleted file mode 100644
+index 2236af7..0000000
+--- a/test/testsmart.cpp
++++ /dev/null
+@@ -1,102 +0,0 @@
+-#include "helpers.h"
+-
+-#include "util/externalcommand.h"
+-#include "backend/corebackend.h"
+-#include "backend/corebackendmanager.h"
+-#include "core/smartstatus.h"
+-#include "core/smartparser.h"
+-
+-#include <QCoreApplication>
+-#include <QDebug>
+-
+-static QString getDefaultDevicePath();
+-static bool testSmartStatus();
+-static bool testSmartParser();
+-
+-int main(int argc, char **argv)
+-{
+- QCoreApplication app(argc, argv);
+-
+- KPMCoreInitializer i;
+-
+- if (argc == 2)
+- i = KPMCoreInitializer(argv[1]);
+-
+- if (!i.isValid())
+- return 1;
+-
+- CoreBackend *backend = CoreBackendManager::self()->backend();
+-
+- if (!backend)
+- {
+- qWarning() << "Couldn't get backend.";
+- return 1;
+- }
+-
+- if (!testSmartStatus() || !testSmartParser())
+- return 1;
+-
+- return app.exec();
+-}
+-
+-static QString getDefaultDevicePath()
+-{
+- // Getting default home partition using 'df -P /home | awk 'END{print $1}'' command
+- ExternalCommand command(QStringLiteral("df"), { QStringLiteral("-P"), QStringLiteral("/home"), QStringLiteral("|"),
+- QStringLiteral("awk"), QStringLiteral("\'END{print $1}\'") });
+-
+- if (command.run() && command.exitCode() == 0) {
+- QString output = command.output();
+- return output;
+- }
+-
+- return QString();
+-}
+-
+-static bool testSmartStatus()
+-{
+- QString devicePath = getDefaultDevicePath();
+-
+- SmartStatus smart(devicePath);
+-
+- if (smart.devicePath() != devicePath)
+- return false;
+-
+- if (!smart.status())
+- return false;
+-
+- if (smart.modelName() == QString())
+- return false;
+-
+- if (smart.firmware() == QString())
+- return false;
+-
+- if (smart.serial() == QString())
+- return false;
+-
+- if (smart.selfTestStatus() != SmartStatus::SelfTestStatus::Success)
+- return false;
+-
+- if (!smart.isValid())
+- return false;
+-
+- return true;
+-}
+-
+-static bool testSmartParser()
+-{
+- QString devicePath = getDefaultDevicePath();
+-
+- SmartParser parser(devicePath);
+-
+- if (!parser.init())
+- return false;
+-
+- if (parser.devicePath() != devicePath)
+- return false;
+-
+- if (!parser.diskInformation())
+- return false;
+-
+- return true;
+-}
+--
+2.17.1