summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/kpackage-allow-external-paths.patch
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-10-23 12:55:22 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-01-04 10:10:46 +0100
commit0fd6138175cb6099e2e5f3d112c3188c84b31561 (patch)
tree46504cad18c7eb5bbf4b66efa16ed3426fb08415 /gnu/packages/patches/kpackage-allow-external-paths.patch
parent16b8aff85bcdb9799496c4a27257210cd45158e5 (diff)
downloadguix-patches-0fd6138175cb6099e2e5f3d112c3188c84b31561.tar
guix-patches-0fd6138175cb6099e2e5f3d112c3188c84b31561.tar.gz
gnu: kpackage: Transfer patches from NixOS.
Transfer the NixOS patches for kpackage as of 2018-02-17: - Allow external paths. - Make QDirIterator follow symlinks. Decided to use a patch for one of the "allow external paths" changes since 'substitute*' seems not to be robust enough. * gnu/packages/patches/kpackage-allow-external-paths.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/kde-frameworks.scm(kpackage)[source]: Use it. <patch>: New phase.
Diffstat (limited to 'gnu/packages/patches/kpackage-allow-external-paths.patch')
-rw-r--r--gnu/packages/patches/kpackage-allow-external-paths.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/kpackage-allow-external-paths.patch b/gnu/packages/patches/kpackage-allow-external-paths.patch
new file mode 100644
index 0000000000..c1c9efde7f
--- /dev/null
+++ b/gnu/packages/patches/kpackage-allow-external-paths.patch
@@ -0,0 +1,13 @@
+diff --git a/src/kpackage/package.cpp b/src/kpackage/package.cpp
+index 5aec9fd..b15c933 100644
+--- a/src/kpackage/package.cpp
++++ b/src/kpackage/package.cpp
+@@ -820,7 +820,7 @@ PackagePrivate::PackagePrivate()
+ : QSharedData(),
+ fallbackPackage(nullptr),
+ metadata(nullptr),
+- externalPaths(false),
++ externalPaths(true),
+ valid(false),
+ checkedValid(false)
+ {