summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/kodi-set-libcurl-ssl-parameters.patch
diff options
context:
space:
mode:
authorCarlo Zancanaro <carlo@zancanaro.id.au>2019-04-02 22:36:57 +1100
committerLudovic Courtès <ludo@gnu.org>2019-04-10 17:09:47 +0200
commit3e4e74c10ec1bf57ffcaed987b75127382908697 (patch)
treef84f9161fb308ec426459ccefadea95a6c2a8e33 /gnu/packages/patches/kodi-set-libcurl-ssl-parameters.patch
parent9c074f61ef1883ae01fcb9daa0c199c46b1ea584 (diff)
downloadguix-patches-3e4e74c10ec1bf57ffcaed987b75127382908697.tar
guix-patches-3e4e74c10ec1bf57ffcaed987b75127382908697.tar.gz
gnu: kodi: Allow connecting to HTTPS sources.
* gnu/packages/patches/kodi-set-libcurl-ssl-parameters.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/kodi.scm (kodi)[patches]: Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/kodi-set-libcurl-ssl-parameters.patch')
-rw-r--r--gnu/packages/patches/kodi-set-libcurl-ssl-parameters.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/kodi-set-libcurl-ssl-parameters.patch b/gnu/packages/patches/kodi-set-libcurl-ssl-parameters.patch
new file mode 100644
index 0000000000..f977c6dd98
--- /dev/null
+++ b/gnu/packages/patches/kodi-set-libcurl-ssl-parameters.patch
@@ -0,0 +1,16 @@
+Kodi doesn't set the CAPATH and CAINFO parameters for libcurl. To make HTTPS
+connections work we can set them based on SSL_CERT_DIR and SSL_CERT_FILE.
+
+--- a/xbmc/filesystem/CurlFile.cpp
++++ b/xbmc/filesystem/CurlFile.cpp
+@@ -626,5 +626,9 @@
+ // Setup allowed TLS/SSL ciphers. New versions of cURL may deprecate things that are still in use.
+ if (!m_cipherlist.empty())
+ g_curlInterface.easy_setopt(h, CURLOPT_SSL_CIPHER_LIST, m_cipherlist.c_str());
++
++ // Load certificate data from environment paths
++ g_curlInterface.easy_setopt(m_state->m_easyHandle, CURLOPT_CAPATH, getenv("SSL_CERT_DIR"));
++ g_curlInterface.easy_setopt(m_state->m_easyHandle, CURLOPT_CAINFO, getenv("SSL_CERT_FILE"));
+ }
+
+ void CCurlFile::SetRequestHeaders(CReadState* state) \ No newline at end of file