summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/kodi-increase-test-timeout.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-19 18:43:11 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-20 00:31:16 +0200
commitf19e571c970ee40902bab1fea3c8654a73caf02f (patch)
tree8031884a1e92958b80cecef47e9b3d5aab0072ea /gnu/packages/patches/kodi-increase-test-timeout.patch
parent28391dc038c71be4ef03c66722b09c90a75b3e55 (diff)
downloadguix-patches-f19e571c970ee40902bab1fea3c8654a73caf02f.tar
guix-patches-f19e571c970ee40902bab1fea3c8654a73caf02f.tar.gz
gnu: kodi: Increase test timeout.
* gnu/packages/patches/kodi-increase-test-timeout.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/kodi.scm (kodi)[source](patches): Add it.
Diffstat (limited to 'gnu/packages/patches/kodi-increase-test-timeout.patch')
-rw-r--r--gnu/packages/patches/kodi-increase-test-timeout.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/kodi-increase-test-timeout.patch b/gnu/packages/patches/kodi-increase-test-timeout.patch
new file mode 100644
index 0000000000..8fb149ff9d
--- /dev/null
+++ b/gnu/packages/patches/kodi-increase-test-timeout.patch
@@ -0,0 +1,18 @@
+Increase thread timeout to reduce flakiness.
+
+Taken from upstream:
+https://github.com/xbmc/xbmc/commit/574b0182d8b641fd24029f372ebdcccc897123e2
+
+diff --git a/xbmc/threads/test/TestEvent.cpp b/xbmc/threads/test/TestEvent.cpp
+index 42fb8c2fc609..40e644c0ed3c 100644
+--- a/xbmc/threads/test/TestEvent.cpp
++++ b/xbmc/threads/test/TestEvent.cpp
+@@ -484,7 +484,7 @@ TEST(TestEvent, GroupTimedWait)
+ EXPECT_TRUE(w3.result == NULL);
+
+ // this should end given the wait is for only 50 millis
+- EXPECT_TRUE(waitThread3.timed_join(MILLIS(100)));
++ EXPECT_TRUE(waitThread3.timed_join(MILLIS(200)));
+
+ EXPECT_TRUE(!w3.waiting);
+ EXPECT_TRUE(w3.result == NULL);