summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/kobodeluxe-const-charp-conversion.patch
diff options
context:
space:
mode:
authorStephen Webber <webber.sl@gmail.com>2016-10-16 15:04:35 -0500
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-10-18 20:23:03 -0500
commita56145e1fa8c8c9cb866518efdeaaf4ad4017ba1 (patch)
tree63cf2172eec05f1d3bf607bbbde0864e832bfb6b /gnu/packages/patches/kobodeluxe-const-charp-conversion.patch
parent91988aee126376ea9e111882afb511e3a555936d (diff)
downloadguix-patches-a56145e1fa8c8c9cb866518efdeaaf4ad4017ba1.tar
guix-patches-a56145e1fa8c8c9cb866518efdeaaf4ad4017ba1.tar.gz
gnu: Add kobodeluxe.
* gnu/packages/games.scm (kobodeluxe): New variable. * gnu/packages/patches/kobodeluxe-paths.patch: New file. * gnu/packages/patches/kobodeluxe-enemies-pipe-decl.patch: New file. * gnu/packages/patches/kobodeluxe-const-charp-conversion.patch: New file. * gnu/packages/patches/kobodeluxe-manpage-minus-not-hyphen.patch: New file. * gnu/packages/patches/kobodeluxe-midicon-segmentation-fault.patch: New file. * gnu/packages/patches/kobodeluxe-graphics-window-signed-char.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/patches/kobodeluxe-const-charp-conversion.patch')
-rw-r--r--gnu/packages/patches/kobodeluxe-const-charp-conversion.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/kobodeluxe-const-charp-conversion.patch b/gnu/packages/patches/kobodeluxe-const-charp-conversion.patch
new file mode 100644
index 0000000000..8386cf83fc
--- /dev/null
+++ b/gnu/packages/patches/kobodeluxe-const-charp-conversion.patch
@@ -0,0 +1,17 @@
+Description: Avoid compilation error with gcc-4.4.
+ "const char* -> char*" conversion is fatal in that version
+Origin: vendor, https://bugs.launchpad.net/ubuntu/+source/kobodeluxe/+bug/461373
+Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/+source/kobodeluxe/+bug/461373
+Bug-Debian: http://bugs.debian.org/552548
+Forwarded: http://www.freelists.org/post/olofsonprojects/kobodlpatch-compile-error-in-windowcpp-with-g44
+--- a/graphics/window.cpp
++++ b/graphics/window.cpp
+@@ -398,7 +398,7 @@ void window_t::center_token_fxp(int _x,
+ */
+ if(token)
+ {
+- char *tok = strchr(txt, token);
++ const char *tok = strchr(txt, token);
+ if(tok)
+ tokpos = tok-txt;
+ else