summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/kio-search-smbd-on-PATH.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-03 19:33:47 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-12 23:49:02 +0100
commitfd11c0fd3df2988831a3aedf136eda211aa69150 (patch)
tree9f375cf2c72f0d540239392312dc03641296218f /gnu/packages/patches/kio-search-smbd-on-PATH.patch
parentcdf7fea183b7159043d17348b5c66325184c7978 (diff)
downloadguix-patches-fd11c0fd3df2988831a3aedf136eda211aa69150.tar
guix-patches-fd11c0fd3df2988831a3aedf136eda211aa69150.tar.gz
gnu: KDE Frameworks: Update to 5.54.0.
* gnu/packages/patches/kio-search-smbd-on-PATH.patch: Adjust context. * gnu/packages/kde-frameworks.scm (kconfig): Update to 5.54.0. [native-inputs]: Add DBUS. [arguments]: Run tests with "dbus-launch". (kio): Update to 5.54.1. [inputs]: Add KCRASH. (breeze-icons): Update to 5.54.0. [arguments]: Remove. (extra-cmake-modules, attica, bluez-qt, kapidox, karchive, kcodecs, kcoreaddons, kdbusaddons, kdnssd, kguiaddons, ki18n, kidletime, kirigami, kitemmodels, kitemviews, kplotting, ksyntaxhighlighting, kwayland, kwidgetsaddons, kwindowsystem, modemmanager-qt, networkmanager-qt, oxygen-icons, prison, qqc2-desktop-style, solid, sonnet, threadweaver, kactivities, kauth, kcompletion, kcrash, kdoctools, kfilemetadata, kimageformats, kjobwidgets, knotifications, kpackage, kpty, kunitconversion, baloo, kactivities-stats, kbookmarks, kcmutils, kconfigwidgets, kdeclarative, kded, kdesignerplugin, kdesu, kdewebkit, kemoticons, kglobalaccel, kiconthemes, kinit, knewstuff, knotifyconfig, kparts, kpeople, krunner, kservice, ktexteditor, ktextwidgets, kwallet, kxmlgui, kxmlrpcclient, plasma-framework, kde-frameworkintegration, kdelibs4support, khtml, kjs, kjsembed, kmediaplayer, kross): Update to 5.54.0.
Diffstat (limited to 'gnu/packages/patches/kio-search-smbd-on-PATH.patch')
-rw-r--r--gnu/packages/patches/kio-search-smbd-on-PATH.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/patches/kio-search-smbd-on-PATH.patch b/gnu/packages/patches/kio-search-smbd-on-PATH.patch
index 47e20cfc0b..55535ffa11 100644
--- a/gnu/packages/patches/kio-search-smbd-on-PATH.patch
+++ b/gnu/packages/patches/kio-search-smbd-on-PATH.patch
@@ -16,7 +16,7 @@ pkgs/development/libraries/kde-frameworks/kio/samba-search-path.patch
+ QLatin1Char pathSep(':');
+ QStringList paths = QFile::decodeName(pathEnv).split(pathSep, QString::SkipEmptyParts);
+ for (QStringList::iterator it = paths.begin(); it != paths.end(); ++it) {
-+ it->append("/smbd");
++ it->append(QStringLiteral("/smbd"));
+ if (QFile::exists(*it)) {
+ return true;
+ }