summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/kinit-kdeinit-libpath.patch
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2018-03-01 23:08:44 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-01-04 10:10:44 +0100
commit16b8aff85bcdb9799496c4a27257210cd45158e5 (patch)
tree9cb829d98ad3269b4d9b8d21d12d51d39b53093c /gnu/packages/patches/kinit-kdeinit-libpath.patch
parentf8a0f3ac708359a72ca136e1c76dfc241a20ea90 (diff)
downloadguix-patches-16b8aff85bcdb9799496c4a27257210cd45158e5.tar
guix-patches-16b8aff85bcdb9799496c4a27257210cd45158e5.tar.gz
gnu: kinit: Use LIBRARY_PATH to search for dynamically loaded libs.
Transfer the NixOS "kdeinit-libpath" patch for kinit as of 2018-02-17. * gnu/packages/patches/kinit-kdeinit-libpath.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/kde-frameworks.scm (kinit)[source]: Use it.
Diffstat (limited to 'gnu/packages/patches/kinit-kdeinit-libpath.patch')
-rw-r--r--gnu/packages/patches/kinit-kdeinit-libpath.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/patches/kinit-kdeinit-libpath.patch b/gnu/packages/patches/kinit-kdeinit-libpath.patch
new file mode 100644
index 0000000000..89cf1a941d
--- /dev/null
+++ b/gnu/packages/patches/kinit-kdeinit-libpath.patch
@@ -0,0 +1,37 @@
+Search libraries in GUIX_KF5INIT_LIB_PATH.
+
+Based on an idea by NixOs
+pkgs/development/libraries/kde-frameworks/kinit/kinit-libpath.patch
+
+===================================================================
+--- kinit-5.32.0/src/kdeinit/kinit.cpp.orig 2017-10-22 21:02:20.908765455 +0200
++++ kinit-5.32.0/src/kdeinit/kinit.cpp 2017-10-22 21:03:25.312818248 +0200
+@@ -623,20 +623,18 @@
+ if (libpath_relative) {
+ // NB: Because Qt makes the actual dlopen() call, the
+ // RUNPATH of kdeinit is *not* respected - see
+ // https://sourceware.org/bugzilla/show_bug.cgi?id=13945
+ // - so we try hacking it in ourselves
+- QString install_lib_dir = QFile::decodeName(
+- CMAKE_INSTALL_PREFIX "/" LIB_INSTALL_DIR "/");
+- QString orig_libpath = libpath;
+- libpath = install_lib_dir + libpath;
+- l.setFileName(libpath);
+- if (!l.load()) {
+- libpath = orig_libpath;
+- l.setFileName(libpath);
+- l.load();
+- }
++ // Try to load the library relative to the active profiles.
++ QByteArrayList profiles = qgetenv("LIBRARY_PATH").split(':');
++ for (const QByteArray &profile: profiles) {
++ if (!profile.isEmpty()) {
++ l.setFileName(QFile::decodeName(profile) + QStringLiteral("/") + libpath);
++ if (l.load()) break;
++ }
++ }
+ } else {
+ l.load();
+ }
+ if (!l.isLoaded()) {
+ QString ltdlError(l.errorString());