summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch
diff options
context:
space:
mode:
authorNicolò Balzarotti <nicolo@nixo.xyz>2020-04-02 11:55:20 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-04-07 17:31:58 +0300
commit1e96e6ac8bc0285cc2adfac4ac29b538b84d5dfc (patch)
tree9140dbe0eb836e8bce3072b1f25232b9012fa2d2 /gnu/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch
parent46e8bc52c26034dbe2deb03ed4956cd1702f6b32 (diff)
downloadguix-patches-1e96e6ac8bc0285cc2adfac4ac29b538b84d5dfc.tar
guix-patches-1e96e6ac8bc0285cc2adfac4ac29b538b84d5dfc.tar.gz
gnu: julia: Upgrade to 1.3.1.
* gnu/packages/julia.scm (libuv-julia): Upgrade to 2.0.0-1.35b1504. (libunwind-julia): New variable. (llvm-patch): Rename to ... (julia-patch): ... this. Update to 1.3.1. (llvm-julia): Adjust patch-set based on above change. Adjust indent. (julia): Update to 1.3.1. [source]: Add patch. [arguments]: Adjust custom 'prepare-deps (llvm-patch): Rename to ... (julia-patch): ... this. Update to 1.3.1. (llvm-julia): Adjust patch-set based on above change. (julia): Upgrade to 1.3.1. [arguments]: Adjust custom 'prepare-deps phase based on changed inputs. Remove most of 'hardcode-soname-map. Adjust 'fix-include-and-link-paths. Add new 'fix-precompile phase. Adjust custom 'disable-broken-tests phase. Add new 'make-wrapper phase. Adjust make-flags. [inputs]: Add p7zip, mbedtls-apache, curl libssh2. Remove openspecfun, fftw, fftwf, python2-virtualenv, rmath. Replace libunwind with libunwind-julia, custom suitesparse with system suitesparse, custom dsfmt with system dsfmt. [native-search-paths]: Add JULIA_DEPOT_PATH. * gnu/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch')
-rw-r--r--gnu/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch b/gnu/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch
new file mode 100644
index 0000000000..32dfd7b856
--- /dev/null
+++ b/gnu/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch
@@ -0,0 +1,28 @@
+--- /dev/null
++++ b/gnu/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch
+@@ -0,0 +1,22 @@
++Fix one of upstream non-determinism, tracked here:
++
++https://github.com/JuliaLang/julia/issues/34115
++https://github.com/JuliaLang/julia/issues/25900
++
++
++Patch by Nicoló Balzarotti <nicolo@nixo.xyz>.
++
++--- a/base/loading.jl
+++++ b/base/loading.jl
++@@ -807,7 +807,10 @@
++ path = normpath(joinpath(dirname(prev), _path))
++ end
++ if _track_dependencies[]
++- push!(_require_dependencies, (mod, path, mtime(path)))
+++ push!(_require_dependencies,
+++ (mod, path,
+++ haskey(ENV, "SOURCE_DATE_EPOCH") ?
+++ parse(Float64, ENV["SOURCE_DATE_EPOCH"]) : mtime(path)))
++ end
++ return path, prev
++ end
+--
+2.26.0
+